1

I've been trying to deploy a big object to Salesforce via the Metadata API in Workbench but for some reason, the object isn't showing up in Salesforce.

Here are the contents of the files in the deploy .zip folder:

Permissions file:

<?xml version="1.0" encoding="UTF-8"?>
<PermissionSet xmlns="http://soap.sforce.com/2006/04/metadata">

    <label>Org Snapshot big obj Permission Set</label>
    <fieldPermissions>
        <editable>true</editable>
        <field>Org_Snapshot_big_obj__b.Sales_Rep__c</field>
        <readable>true</readable>
    </fieldPermissions>

    <fieldPermissions>
        <editable>true</editable>
        <field>Org_Snapshot_big_obj__b.Top_Tier_150__c</field>
        <readable>true</readable>
    </fieldPermissions>
</PermissionSet>

Object file:

<?xml version="1.0" encoding="UTF-8"?>
<CustomObject xmlns="http://soap.sforce.com/2006/04/metadata">
    <deploymentStatus>Deployed</deploymentStatus>
    <fields>
        <fullName>Organization_Name__c</fullName>
        <label>Organization Name</label>
        <length>50</length>
        <required>true</required>
        <type>Text</type>
        <unique>false</unique>
    </fields>

    <fields>
        <fullName>Sales_Rep__c</fullName>
        <label>Sales Rep</label>
        <length>50</length>
        <required>false</required>
        <type>Text</type>
        <unique>false</unique>
    </fields>

    <fields>
        <fullName>Top_Tier_150__c</fullName>
        <label>Top Tier 150</label>
        <required>false</required>
        <length>120</length>
        <type>Text</type>
        <unique>false</unique>
    </fields>

    <fields>
        <fullName>CreatedBy</fullName>
        <required>false</required>
        <referenceTo>User</referenceTo>
        <type>Lookup</type>
    </fields>
    <indexes>
        <fullName>OrgSnapshotIndex</fullName>
        <label>Org Snapshot Index</label>
        <fields>
            <name>Organization_Name__c</name>
            <sortDirection>DESC</sortDirection>
        </fields>
    </indexes>

    <label>Org Snapshot Big Object</label>
    <pluralLabel>Org Snapshots</pluralLabel>
</CustomObject>

Package.xml

<?xml version="1.0" encoding="UTF-8"?>
<Package xmlns="http://soap.sforce.com/2006/04/metadata">
    <types>
        <members>*</members>
        <name>CustomObject</name>
    </types>
    <types>
        <members>*</members>
        <name>PermissionSet</name>
    </types>
    <version>41.0</version>
</Package>

The folder structure is:

objects
  Org_Snapshot_big_obj__b.object
permissionsets
  Org_Snapshot_big_obj.permissionset
package.xml

Results:

enter image description here

When deploying the package, I only selected the options of "Single Package" and "Check Only." Even though the results are displaying that the deploy operation was a success. Nothing is being displayed in the big objects section in Salesforce. Is there anything incorrect in the process outlined here? What might be causing the issue?

8

When you deploy "Check Only", you are just validating, not actually committing your changes. Remove that selection (i.e. Select only Single Package) and you will be good to go.

Note: As stubborn for consistency that I am, I would recommend that you do not add the suffix "_big_obj" to your object. The "__b" at the end does that for you and you lose valuable characters in the name that could come handy in other objects. My advice is 100% personal, though, just thought I'd share it.

  • 1
    Thanks, they didn't really explain this in the documentation. – loremIpsum1771 Apr 23 '18 at 15:55

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.