34

What's going on with the layouts/User-User Layout.layout metadata file? I have scripts that snapshot all of my metadata every day. Ever since we upgraded to Winter '14, the following lines are appearing or disappearing every day. One day they're included in the metadata file, and the next day they're gone, alternating constantly. Anyone know what's going on with this?

<relatedObjects>UserRoleId</relatedObjects>
<relatedObjects>ProfileId</relatedObjects>
<relatedObjects>DelegatedApproverId</relatedObjects>
<relatedObjects>ManagerId</relatedObjects>
<relatedObjects>ContactId</relatedObjects>
<relatedObjects>AccountId</relatedObjects>
<relatedObjects>CallCenterId</relatedObjects>
<relatedObjects>ProfilePhotoId</relatedObjects>
<relatedObjects>WorkspaceId</relatedObjects>
  • 2
    I don't have an answer as to why but I can definitely acknowledge the behavior. We have the same setup which runs hourly and checks things in to Git. Over the last couple of days (weeks?) we've observed the same as you're describing. Makes it very difficult to see when "real" changes happen to the object... – JLiljegren__c Oct 22 '13 at 13:43
  • Same issue here. The same elements also appear in the Layout metadata for User as well – BarCotter Oct 22 '13 at 17:38
  • Has this settled down, or is it continuing to happen? – tomlogic Dec 2 '13 at 22:15
  • Yup, it's still going on. – Benj Dec 3 '13 at 20:59
  • 2
    Has anyone logged a case with salesforce.com about this oddity? Or has anyone seen any differences since Spring '14 (went live on NA1 last week)? – Marty C. Feb 19 '14 at 2:25
2

It would be the best to log a case with Salesforce.com Developer Support

0

Are you guys still experiencing these issues? We're using Copado Deployer from the AppExchange to perform backups and have not noticed anything out of the ordinary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.