11

Winter 14 - sandbox cs9

I have 50+ test classes; I do Apex Test Execution | Select tests | select all.

  • Disable parallel testing = true
  • Store only aggregated test coverage = true

I select all tests. Within a few minutes, about 40 of the test classes finish execution; 10 or so never finish. Even after one hour of waiting. This never used to happen as I have done this sequence repeatedly over the last few months/years. This makes it hard to run regression tests.

Things I tried:

  1. Taking one of the 'never finishing' classes, aborting it, and running it solo. RESULT: It never finishes execution
  2. Recompiling one of the 'never finishing' classes and running it solo. RESULT: It never finishes execution
  3. Using Eclipse Force.com IDE and Apex Run Tests on one of the manually-aborted, 'never finishing' test classes - Eclipse comes back with 'Unable to run tests on 'Foo.cls': Running test: Foo, time spent on that test 1974ms, total time spent running tests 18715ms. Error: UNKNOWN_EXCEPTION: An unexpected error occurred. Please include this ErrorId if you contact support: 170253947-20552(2105728326)
  4. Refreshed fullcopy sandbox (cs11) from PROD 30 minutes ago. Ran tests on one of the classes that 'never finished' in cs9 - same error in CS11. Note that test of said class in PROD passes

Analysis - based on #4, it would appear something was introduced into at least cs9 and cs11 sandboxes that prevent certain test classes from executing. Given that cs11 is a fullcopy of PROD and class Foo runs fine in PROD but not in cs11 (fullcopy), the problem must be related to sandboxes

So, I contacted support. Waiting for assistance.

  • OK, support states that this is a known issue relating to a recent patch involving code coverage and that SFDC India is working on it as I type. Error code is 2105728326. They didn't identify the specific patch but is related to one of these I would surmise: success.salesforce.com/issues_index?tag=Winter%2014 – cropredy Nov 7 '13 at 22:04
  • Looks like SFDC may have backed out the fix to: success.salesforce.com/issues_view?id=a1p30000000T0FeAAK as my tests now execute but with the Red X and error 'tests cannot be run for class <id>' - however, double clicking the line shows that all testmethods passed – cropredy Nov 8 '13 at 5:32
2

Problem resolved by SFDC by applying patch or rolling back patch in CS9 (hard to tell what they did). All tests now execute to completion. None show 'Red X could not run tests on class ' Should someone still be experiencing this, they can reference SFDC Support Case 09880471 and apparently related case 09881682

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.