0

I have a lightning component in my community (Partner Central template).

It works well, but I needed to make some changes, so I have done all my changes in my sandbox and deployed to my production via ant.

After a successful deploy of all components, the community still uses the old version of my component - how can that be?

In Salesforce dev-console - the code shows the new version, in chrome dev-tools the html is of the old version.

How can that be?

Do I miss something?

BTW - it is an active community and I have publish changes although changes where made only for the component.

Thanks Itai

0

Problem is solved.

I have tried many things but all failed - even adding the component to an object's record page - this showed the new version, but the community still showed the old version.

So eventually, I changed the code of the component on my production (just added a dumb line, via developer console, and saved it - only after that, my community refreshed the component and showed the new version.

I believe this is some kind of a bug, but anyway - now all is OK.

Itai

0

The same thing just happened to us. Page was returning a blank page. Went in and edited the javascript part of the page (js) , and resaved and then the page started working. Would be nice to know why this worked. No code was changed!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.