1

If I deploy the lightning community, in destination org I see the community as classic.

No matter what I do or how many times I redeploy, the outcome is same. I even tried comparing the metadata locally, no differences.

The value of setting Enable ExperienceBundle Metadata API doesn't make any difference.

Even the login page type shows as default page which is classic:

enter image description here


Background:

Had to convert the classic to lightning communities and the older community was build with basic OOTB features.

  • I was easily able to create a new lightning (based on the old classic community) on our DEV environment.
  • Used partner central template.
  • Next was easy step to do the deployment.

Now I had heard/read issues with lightning community deployment but this time I was lucky to experience this issue myself.

We have our CI/CD process with copado (copado here is not very relevant as I have same problem with SFDX/ANT migration tool and even changeset).

Following components I tried to deploy with changeset (and other tools):

enter image description here

Reference articles:

  1. Deploy Lightning Communities

  2. Deploy a Community from Sandbox to Production

1

After wasting roughly a week and some rest found a workaround/solution today.

Trick to get this right in such circumstance is:

  1. Deactivate the community in destination org.
  2. Redeploy the community from source environment.
  3. After deployment, publish the lightning community.
  4. Profit!

Now after deployment with these steps I was able to get the correct lightning version community in my destination orgs. And the login page also correct after deployment.

enter image description here


Note: Posting the solution here for anyone else having similar problem in future. Please feel free to mark this as duplicate if there is similar question that I could not find.

2
  • out of curiosity, did you try using the ExperienceBundle metadata type in a change set vs. using the site.com and did you run into the same issue? Aug 11 '20 at 17:00
  • Hi @Kris, I just checked my previous commits, I did try after enabling the Enable ExperienceBundle Metadata API in source org, then did a pull to get changes and tried to deploy via copado and force.com migration tool. No luck, didn't try that specific scenario with a changeset. It had bunch of files under the folder experiences/Partner_Lightning1/*/*.json (about 111 JSON files).
    – Raul
    Aug 11 '20 at 17:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.