I have a component that is not showing on Community Builder.My managed package app has a component and one of our customers has an issue where we cannot see the Lightning Component in the Community Builder >> Custom Components. I am wondering if that could be permission?

Here are the things that I have verified.

1 - In the component I have set forceCommunity:availableForAllPageTypes.

<aura:component implements="forceCommunity:availableForAllPageTypes" access="global" controller="XXXComponentController" >

2 - The Customer has deployed the Domain to users.

3 - We can see other components on Community Builder >> Custom Components(Those components are all created manually not from managed package).

4 - If I install the same app version in a new org, I can see the component.

My questions are: 1 - Is there any Permission Set that I need to set? 2 - Is there anything else I could check? 3 - If I enable the Debug mode, which information I should look for in the console?

Thank you in advance!

3 Answers 3


I created a new version and I pushed to the customer again, and seems to solve the issue, somehow it shows the component in his org. Thank you for all the answers.

Updated on: 2019-09-27
Another way to solve this issue is to compile all the Apex classes.


The only thing I see missing is number three here. (Configure Components for Lightning Pages and the Lightning App Builder)

"3. Add a Design Resource to Your Component Bundle"

Other than that your description sounds about right and I can't think of anything else without looking at it.

  • Thank you for answering, yes, I have the Design Resource. =) This component shows fine in my test org, dev org, my test enterprise hub org. Dec 5, 2017 at 14:49

Have you make your Component as Global Component? If you want your component to be visible in managed package org then you need to make component global.

<aura:component access="global">
  • Hi Manjot, thanks for answering, yes, I have that. Dec 5, 2017 at 18:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.