4

on my account object, I created a picklist field - testPicklist1__c. The picklist field has various values in it. One picklist value is "abc t" & its API name is "abc". I retrieved the Account object using ANT & tried to deploy to another Salesforce org using ANT. I got the below error message -: enter image description here

Error Message says -: "Picklist value: abc t in picklist: testPicklist1__c not found".

When I viewed the Account.object file I found that under "testPicklist1" field definition, the picklist value is shown with full name "abc" like this <fullName>abc</fullName> as shown below -:

<fields>
    <fullName>testPicklist1__c</fullName>
    <externalId>false</externalId>
    <label>testPicklist1</label>
    <picklist>
        <picklistValues>
            <fullName>abc</fullName>
            <default>false</default>
        </picklistValues>  
    </picklist>
</fields>

Wheras in "AOC" record type definition under the enabled picklist value, this picklist is being referenced using "abc t" as the full name like this <fullName>abc t</fullName> as shown below -:

<recordTypes>
    <fullName>AOC</fullName>
    <active>true</active>
    <label>AOC</label>
    <picklistValues>
        <picklist>testPicklist1__c</picklist>
        <values>
            <fullName>abc t</fullName>
            <default>false</default>
        </values>
    </picklistValues>
</recordTypes>

Is this what causing the above error ? How can I remove this error & deploy successfully without manually doing changes ? Thanks in advance.

  • I would pull the data from the source org again in the expectation that the values would be consistent. Or manually change. – Keith C Apr 25 '17 at 9:51
  • Pulling again does not solve the problem. I think it is a bug when we retrieve picklist values using ANT from an org. – Tushar Arora Apr 25 '17 at 15:22
4

Oh! I was missing the latest metadata API version which is for the picklist API name feature that was added in Spring ’17 release. I retrieved after changing package.xml to version 39 and then deployed and it worked. https://developer.salesforce.com/blogs/developer-relations/2017/01/keeping-picklist-integrations-safe-using-api-names.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.