0

I edited and tested two flows in my SB that they now use the new Flow winter '20 feature whereby in 'Get Records' step I am letting SF automatically define the record variable (getCandidateQnRecord) rather than me manually assign field values to variables

get records step

Then in the next few steps I have screen components. The UI components are pre-defaulted by values in the properties/field of getCandidateQnRecord. I then use an assignment step to assign the values from the screencomponent that the user might have changed back into fields/properties of getCandidateQnRecord.

assignment step

And then in the 'update records' step I am updating the SF DB with getCandidateQnRecord -> which should now have all the updated values and over-write the fields in the db.

update records step

Everything is working fine locally.

however, when I package it up and SF admin tries to deploy they are getting the below error (our package.xml is on 47.0 which supports this new feature; I think he tried to change it to the latest (49.0) and that didnt help either):

3. flows/Candidate_Questionnaire.flow -- Error: updateCandidateQnRecord1 (Update Records) - The sObjectInputReference field can reference only elements with data type SObject. Replace the value "getCandidateQnRecord".

Any ideas? We have tried to do 'ant retrieve' and then 'ant deploy' in our local SB and all is fine -> perhaps SF is not deploying properly on our local SB hence not an equivalent test?

0

this ended up being a non-issue

for some reason the following lines did not get added to the package properly and were the cause of the problem (they are new lines as part of Winter 20):

    <getFirstRecordOnly>true</getFirstRecordOnly>

..

    <storeOutputAutomatically>true</storeOutputAutomatically>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.