7

I have a Lightning Community with Napili template and since Winter '17 release Custom Labels don't show up. Instead of the translation I get this message.

$Label.c.LabelName does not exist.

Where "LabelName" is the Name of the Custom Label.

I guess it means that it gets the Custom Label but not the translation.

Is this happening to anyone?

7
  • any chances you have checked known issues if any logged? Sep 13, 2016 at 11:10
  • Yes, and I found nothing... :( Sep 13, 2016 at 11:36
  • 2
    I am experiencing the same issue since Winter 17.
    – svenf
    Sep 13, 2016 at 13:18
  • 1
    Happening to me also since Winter 17
    – Wookie88
    Sep 13, 2016 at 14:12
  • I am getting "$Label.NAMESPACE.LabelName could not be retrieved from custom labels: null". The strange thing is the same packaged components work in most Winter '17 orgs, I've only found one demonstrating the issue so far. The strangest thing is on initial load the label resolves, then the error message shows, then if you move the component again the error messages disappear until you open the builder again. Sep 13, 2016 at 21:11

2 Answers 2

6

I've contacted Salesforce support and here is what I got so far :

I have investigated and replicated this issue on my Winter'17 Dev Org. I found that the custom label displays properly if the user language is same as that of the custom label language.

If we change the language of user to some other language than that of the custom label, we get this error.

This behavior is not happening in Summer'16 Org. Another thing I have tested is that when translation settings are turned on, it seems that the error doesn't happen.

I am escalating this further for Tier 3 attention. In the meantime, the workaround would be to make sure custom label and user language is same.

EDIT 09-22 : update from SF Support

I have got an update from Tier 3 that this is a bug that has been acknowledged by R&D. They are working on priority to release a fix which should get done by next week (safe harbor).

EDIT 09-29 : fix released

Salesforce seemed to have released the fix for that. My instance is working fine now.

1
  • I tried this but no luck. User and Label language - English. Not translations placed for custom label. Sep 21, 2016 at 22:07
0

Sorry cannot leave a comment yet.

Having a similar problem since Winter 17 but not in Community. I created a Lightning tab to use it in SF1 that includes a custom label. this works just fine as long as I dont change the user language. changing the language gives me the same error "label does not exist".

The release notes contain some improvements to custom labels (using them from managed packages). So maybe this "improvement" came along with a new bug ...

1
  • Update: it works if there is a translation for the particular language. So it does not get the default english label anymore ...
    – MS88
    Sep 14, 2016 at 8:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.