0

I have created a Landing Page in CloudPages. I am trying to personlize the URL following the below documentation -

Personlized URLs

In my email, I made the URL like below but it is not working. I cannot see the personalized string values in the Landing page. What could be wrong?

<a href="http://pub.s7.exacttarget.com/yjn1dc44444?subscriberkey=%%_subscriberkey%%"
alias="Join Us">Join Us</a>
1

I dealt with this issue a few weeks ago and did not need PURL enabled. Here is the solution that's working for me with landing pages (Cloud Pages) and a lookup to a data extension.

I've attempted to adapt it for your sitaution.

  1. Add this AMPscript to your landing page in an HTML block. You must set this block on the top layer of your page for it to work.

    %%[
    var @subscriberkey, @firstname
    set @subscriberkey = RequestParameter("[data extension]")
    set @firstname = Lookup("[data extension]","FirstName","subscriberkey",@subscriberkey)
    ]%%
    
  2. In your landing page you would reference the FirstName with the following AMPscript:

    %%=v(@firstname)=%%
    
  3. Construct your link like this (include the actual subscriber key in place of 12345):

    <a href="http://pub.s7.exacttarget.com/yjn1dc44444?subscriberkey=12345">Join Us</a>
    
  • Thanks to Eliot Harper for the original solution to my question: salesforce.stackexchange.com/questions/138733/… – Karl Barndt Sep 20 '16 at 17:51
  • I want to update into a Salesforce custom object .. Not any data extension – Maneesh Sep 20 '16 at 17:55
  • I didn't see where you wanted to insert or update the data into a SF custom object. Without coding it, you probably need to create a Journey to update your SF object. – Karl Barndt Sep 20 '16 at 20:58
  • Oh my bad! I responded to the wrong post here! – Maneesh Sep 20 '16 at 21:03
0

First I need to verify you meet the requirements to use the PURL:

  • You must purchase Landing Pages.
  • You must contact you Salesforce Marketing Cloud to activate the PURL feature.
  • You must have a domain or subdomain configured in your account specifically for landing pages. However, the domain must not be identical to the domain used for SAP, but it may be a subdomain of the SAP. The client can use the same domain as their website as long as "pages." is at the beginning of the domain. For example, if the domain used for SAP is myaccount.com then the client could use pages.myaccount.com for the landing pages.

If you meet those requirements, then I believe the issue is that you need to add the email address or subscriber key after the last forward slash, not as a parameter.

Add the Email or Subscriber Key substitution string to the end of the URL by including %%emailaddr%% or %%_subscriberkey%% into the URL after the last forward slash.

(https://help.marketingcloud.com/en/documentation/exacttarget/content/landing_pages/friendly_and_personalized_urls/)

See below:

<a href="http://pub.s7.exacttarget.com/yjn1dc44444/%%_subscriberkey%%"
alias="Join Us">Join Us</a>
  • I tried that but it throws a 404 server error. This is what the URL renders into - pub.s7.exacttarget.com/yjn1dc44444/… – Maneesh Jun 15 '16 at 17:50
  • it won't provide me details into the error as I am not on your network. Have you verified all AMPscript and SSJS inside the email are valid with your subscribers? – Gortonington Jun 15 '16 at 17:53
  • There is no SSJS or AMPScript in the email (except this above URL) – Maneesh Jun 15 '16 at 18:03
  • not the email, on the cloud page I meant. – Gortonington Jun 15 '16 at 18:04
  • The only that is there on the Cloud page is below - Subscriber Key = %%_subscriberkey%% FYI - I am not using any Microsite. Its a standalone cloud page. Is that okay ? – Maneesh Jun 15 '16 at 18:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.