I need to populate one new custom field on Lead object in all the lead records for reporting purposes.

What I tried:

The first problem I encountered was with leads already converted. The error message looked like:

cannot reference a converted lead

In Spring'16, Salesforce released new permissions that allow users to update fields on converted leads (Release Notes).

So I activated these permissions on my custom Admin profile (Modify All in all objects). Then I tried to update a converted Lead using Developer Console (query, edit a few and click Save Rows) and it worked.

As I have to update 80k+ Leads, usign the UI/Console is discarded.

So I tried with DataLoader. I get rid off of my first error message but a new one appeared:

first error: INSUFFICIENT_ACCESS_OR_READONLY, insufficient access rights on object id: []

Then I tried Apex Script and Batch Apex; same error.


Why I'm getting a INSUFFICIENT_ACCESS_OR_READONLY error if I'm logged in as a System Administrator?

I'm missing something at this point? Maybe some other permission, or something related with teams?

I read some workarounds on the internet (delete records and insert them again) but I don´t really like them.

More info:

  • I'm still unable to update leads using the Salesforce Classic UI. When I click Edit, I land on ViewConvertedLead standard page.
  • OWD Sharing Setting for Leads is set to Private

Thank you all in advance.

  • 1
    What version of dataLoader are you using?
    – cropredy
    Commented Feb 29, 2016 at 17:40

2 Answers 2


I came across the same error and managed to get it to work by reducing the batch size in Data Loader down to 1 and the Use Bulk API option checked, not ideal for updating 80k+ records but that's the only way I found.

  • Thank you for the info. I tried with batch size set to 1 and it worked (independently of Use Bulk API check). Now I have to wait 10 hours more or less to get this finished... what a pain... Thanks again.
    – mlaso
    Commented Mar 1, 2016 at 9:19

This is a permissions issue, you must have the correct permission assigned to the API user (or data loader user).

I was having the same issue until I granted the right permission to the API user.


  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jun 1 at 17:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .