2

I'm trying to do a bulk update of 141 records on a custom object (A2D) using Data Loader. In this bulk update, I have mapped the id field and about 8 boolean fields. When the update is attempted, I get the same error message across all records. The error usually resembles a process failure, accompanied by a 'limit exceeded' error.

An example of this looks like:

We can't save this record because the 'System Pick - Update System_Pick_at_First_System_Rec' process failed. Give your Salesforce admin these details. This interview has been terminated as another interview in the same bulk execution request failed with the following error: <b>Limit Exceeded</b><br>You or your organization has exceeded the maximum limit for this feature. Error ID: 749506045-162554 (-1741830137)

If I don't make changes to anything and attempt to bulk update the same set of records again, the process that failed usually updates to another process I have set up via process builder. The strange thing I see here is, the process builder workflows that are stated to fail from Data Loader should not run unless specified changes are made to a record. In the case of the bulk upload I'm trying to accomplish, I am not updating any of the fields from the criteria that would trigger the processes Data Loader states caused a failure.

In terms of the 'Limit Exceeded' message I get in each error - I have opened the Developer Console and viewed logs. I understand the logs will return Event lines titled 'LIMIT_USAGE_FOR_NS' that can show where limits have been exceeded. Upon reviewing these, however, I'm not seeing anywhere that shows an exceeded limit. Because there are multiple 'LIMIT_USAGE_FOR_NS' sections in my log, I will not list all of them, but here's an example of what I mean...

LIMIT_USAGE_FOR_NS Photo

I've also checked our Org's 'System Overview' and we seem well under limits here.

System Overview Photo

I'm pretty new to troubleshooting via SF, so any assistance on where else I can check or help with figuring out what's going on would be awesome. Thanks!

1
  • 1
    Could be a workflow/trigger updating the record in turn triggering process builder? Check for any workflows/apex triggers on update Commented Sep 8, 2021 at 0:54

3 Answers 3

1

There is a Flow/Process Builder in your org, with the API name "System Pick - Update System_Pick_at_First_System_Rec"

What you need to do is deactivate this - attempt your data load and then reactivate it. It seems to be running for more than one records in your batch and invoking multiple recursions that are attributing to this limit.

2
  • 1
    After review, I definitely agree the limit is being hit. However, I do not understand why this Process Builder with the API name "System Pick - Update System_Pick_at_First_System_Rec" is even running. It should only run when the 'Date/Time First System Rec' field is updated to not be null. I am not updating this field in the bulk update I'm attempting, so why is this process even running? Commented Sep 8, 2021 at 16:18
  • @AlexisFrisch - The triage of why its firing is out of scope of the question posted. Other reasons, like an apex trigger or another workflow firing that is updating the date/time first system Rec field, which in turn causes this process builder is getting invoked like a cascade effect. Can you deactivate the process builder as suggested in this answer and retry please ? If this resolves please mark as answer accepted.
    – Sid
    Commented Sep 8, 2021 at 16:26
1

Sid's suggestion of deactivating the failing Flow/Process Builder is a valid one. However, our organization has multiple processes running on one record. I was able to solve this and have my bulk update process without any errors by changing the Batch number to '1' instead of the default '200' - Solution located here.

0

I got this same error when I was updating with Dataloader.

Setting the Dataloader batch size to 1 solved the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .