7

I created a changeset and deployed around 40 custom objects to another sandbox. On the destination sandbox, the custom fields dont show up on the page layout when i edit or add a new record for the custom object.

I know it is a permission issue and i am using the system admin profile to login to the destination org. How can i deploy one time all my custom objects, fields, pagelayouts from my current sandbox to destination and ensure all of these show up on the layout?

Could you guys let me know on this?

Thanks

Buyan

  • 1
    On the bottom of a change set page you can add profiles. – Samuel De Rycke Apr 30 '13 at 8:19
7

To make your new custom field visible on the target org after deploy:

  1. Go to your personal "Setup" area - "Manage Users" - "Profiles" - and select your profile name.

  2. You will see your profile details (quite a long page with lots of information). In our case we need "Field-Level Security" area (because of our element-type "Custom Field"). Now find the object name your new custom field belongs to and click on the link "[ View ]". You will be redirected to another page with all custom fields of the custom object where you can cange the visibility of custom field.

  3. If the custom field is not visible - click on the "Edit" button on the top of the page, select the checkbox and save you setting (click on the "Save" button).

enter image description here

  • 2
    ... and if it's a lookup field, double check that user has at least "Read" access to the target object (which is not a problem for SysAdmins with their "Modify All Data" but can cause some frustration for end users). – eyescream Apr 30 '13 at 6:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.