5

We tried to deploy a custom profile from one dev org to another org using changeset. It fails on validation on the destination org and we get an error message invalid parameter type. Would any body know where to get started on debugging the error message? Thanks Buyan

  • is the error message coming from a test class, can you paste a screen shot of the error message if possible – Rao Apr 2 '14 at 18:34
  • @rao The error message does not say which component is causing the problem. It just lists profile name and error message and no line number or anything. – buyan kumar Apr 2 '14 at 18:40
  • Have your run all tests in the destination org before try the deploy ? – Martin Borthiry Apr 2 '14 at 19:22
  • What is the exact message? Does it say which parameter type is invalid? – JimRae Apr 2 '14 at 20:41
3

The reason is this: When you simply deploy a new Profile, the API auto-clones the Standard User or Standard Platform Profile (depending on license associated with Profile being deployed) before overlaying the security settings with the Profile metadata that you are deploying. But, not all permissions are overwritten as negative values are denoted by absences in the Profile XML. So, there are conflicts.

This is solved by you executing your own Profile clone and then deploying.

Makes sense?

Sridhar

|improve this answer|||||
3

Manually create the Profile and don't bother about permissions .Once manually create deploy the same changeset .It succeeds .Still dont know actual cause but it worked .Thanks

|improve this answer|||||
  • Thanks @Mohith it helped me, when i validating the package with my prod haven't seen this error but while deploying this error popped up no idea what kind of error it is your Answer helped in my situation when everything is dark outside no info provided any were. – Vivek P Jan 14 '17 at 1:11
1

@Mohith Kumar Thanks for your answer. The problem was that we tried to deploy new profiles in our changeset which did not exist in our destination org. These new profiles were created by our development team and did not exist in our refreshed sandbox org from production. Salesforce just reports this as an invalid parameter type error instead of specific error message. During deployment, please make sure the profiles exist in the source and destination org.

|improve this answer|||||
  • .Please mark the answer as answered so it helps everyone .Thanks – Mohith Shrivastava Apr 4 '14 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.