1

We are setting up an integration from netsuite to salesforce and we encounter a problem with the response netsuite gets from salesforce. The integration seems to be working well - We get the request, we create the data in salesforce and send a response with success status.
The problem is that netsuite gets an error from salesforce (see below).
We tried it on 2 different salesforce sandboxes and we encounter the same problem.
We tried opening a case to salesforce but the closed it because we do not have a development support.
Do you have any suggestions why we get this notification and/or what we can do about it?

The error netsuite gets from salesforce:


An internal server error has occurred
An error has occurred while processing your request. The salesforce.com support team has been notified of the problem. If you believe you have additional information that may be of help in reproducing or correcting the error, please contact https://help.salesforce.com/apex/hthome\">Salesforce Support. Please indicate the URL of the page you were requesting, any error id shown on this page as well as any other related information. We apologize for the inconvenience.

Thank you again for your patience and assistance. And thanks for using salesforce.com!

Error ID: 1867462533-18494 (-412090138)

3

This:

Error ID: 1867462533-18494 (-412090138)

is what Salesforce term a gack - see the official documentation What Is A Gack?. It is basically a condition that isn't handled well by the platform. While it would be great if Salesforce fixed the platform every time one occurs, changing your code to avoid the problem is the more realistic approach.

You could go it alone and make somewhat random changes i.e. review your code and compare with specs and other code and make changes. Or you could engage with Salesforce support so they can lookup their internal logs using the id values in the message and so hopefully narrow down the problem area and guide you to the code to modify; that may take a couple of days. Going that route, it could also turn out to be a platform bug for which there is no work-around resulting in a patch platform fix (weeks later) or a fix in a future platform release (months later).

  • Keith, thank you for the answer. You mentioned that i can change the code in order to avoid this error. I checked this endpoint with a simple c# application and i didn't get this error. This error appears only when the request origin is netsuite. Do you have any idea how i can change the code to avoid this error in this specific case? This is a very simple endpoint that creates a log record with the data from the request and returns success notification. According to the debug log, we get to the point where we return success but netsuite gets the salesforce error mentioned above. – Dagish Nov 8 '15 at 13:25
  • 2
    @Dagish Might be worth searching Netsuite forums and raising a support case with them in case it is a well-know problem between the two systems. Other than that, routing the working request and the non-working request through a proxy such as tcpmon and looking at what is different might shed some light. – Keith C Nov 8 '15 at 14:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.