I was trying to connect to my dev org using my force.com IDE and i got an exception

"com.salesforce.ide.api.metadata.types.Metadata$JaxbAccessorF_fullName cannot be cast to com.sun.xml.internal.bind.v2.runtime.reflect.Accessor"

Any idea on what could be the reason for this?

4 Answers 4


I found a workaround

Switching the workspace back to the same workspace you had problem with solved it.

File -> Switch workspace -> [Select the same workspace you had problem with]

Not sure why it worked.. But it WORKED :)

  • 1
    Workaround worked for me, and I also don't know why it worked :)
    – user917
    Mar 19, 2013 at 0:38

Not that you'd necessarily be able to do anything about it, but have you tried to run the IDE in debug mode? There's more on it in the Eclipse help section: Force.com IDE Library > Using the Force.com IDE > Reference

Running the Force.com IDE in Debug Mode

If you experience errors in the Force.com IDE, it can be useful to run Eclipse in Debug Mode. This will cause the IDE to write additional information to its system log.

To run the IDE in Debug Mode, add the following parameter to Eclipse's startup command line or in eclipse.ini:

  • -Dforce-ide-debug=true

For more information on the Force.com IDE system log, see Force.com Log Viewer.

You can also write the zip file to disk for each save, refresh, synchronize, or deploy action, which can be helpful in diagnosing errors. Add the following parameter to Eclipse's startup command line or in eclipse.ini

  • -Dforce-ide-temp=<full-path-to-directory>

Force.com Log Viewer

As the Force.com IDE runs, it writes certain events to a system log file stored in your Eclipse workspace. If you encounter exception messages or other problems while using the IDE, the information in this log file may help you diagnose and resolve the issue. The Force.com Log Viewer provides an easy way to see the contents of the IDE system log or to locate the file so you can provide it to Salesforce customer support.

To show the Force.com Log Viewer:

  • In the main menu bar, click Help | Show Force.com IDE Log

You can make the Force.com IDE write more detail to its system log by running the IDE in debug mode. For information, see Running the Force.com IDE In Debug Mode.

Note: In order to show you new events as they occur, the Force.com Log Viewer frequently refreshes itself from the log file on disk. This activity may slow your system, so it is recommended that you keep the Force.com Log Viewer closed during normal use of the IDE.


Java errors like this one seem to be fixed by compacting the Workspace, which will happen with File/Restart or File/Switch Workspace, either one. This is my default way to fix Eclipse when it starts acting weird.

Maybe it's just me, but I've been having to do this a lot more since upgrading to Spring 12; like 2 or 3 times a week. Maybe we'll gain some stability with the next one.


I know this is old, but I just hit this error in a customer's environment and found a different cause/solution. Using Eclipse 3.6 on a machine where the only VM was a Java 1.7 JDK caused this error. The fix was to install a Java 1.6 JDK, and use the "-vm" setting in Eclipse.ini to point to the 1.6 JRE.

  • I tried to follow the advice here and add the -vm switch to eclipse.ini but could not get this to work. Is there a specific 1.6 version that is needed?
    – user11413
    Sep 5, 2014 at 21:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .