Winter '15 brought new Global Variable $Permission. When I'm trying to use it on VF page as suggested in documentation $Permission.[customPermissionName], I get error:

Error: Field [customPermissionName] does not exist. Check spelling

VF page version is 32. I also tried to add prefix 'can' but it didn't help.

Does anybody seeing the same behavior?

  • Can you post a sample of your code?
    – BradByte
    Nov 25, 2014 at 15:53

1 Answer 1


This works for me. But I tried it an an org that has a namespace defined and got the same error you got unless I included the namespace prefix ("cve" in my case). So for me with a custom permission name of "Abcd" this didn't work:


but this did:

  • Maybe specifying the default namespace c__ would resolve this particular issue? {!$Permission.c__Abcd}
    – Mark Pond
    Nov 25, 2014 at 16:56
  • Thanks @Keith that works!@Mark, looks like specifying c__ doesn't work. Nov 25, 2014 at 17:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .