14

Has anyone found a way to have a field, which is a formula field that uses HYPERLINK(), to display correctly in the Salesforce1 APP?

Currently in the browser based Salesforce1 it functions correctly, however in the APP it displays the raw HTML (i.e. <a href=.......)

I found an Idea that was 4 years old and based on "Salesforce Mobile" seems the problem has carried over to Salesforce1 APP.

UPDATE:

Support has replicated this issue and it is now in tier 3 for a fix.

  • 1
    On a VF page, you can use <apex:outputtext> with escape=false. I'm not so sure about a standard field though... – Jonathan Hersh Aug 5 '14 at 23:13
  • Yea, that has nothing to do with this. I am simply displaying a field in the standard list view – Eric Aug 5 '14 at 23:18
  • 1
    Could you answer your own question, and then accept it? – Willem Mulder Oct 1 '14 at 9:51
  • @WillemMulder - i wish I could, I have not been given an answer yet. AFAIK it is still out there. Never notified of a fix to date. – Eric Feb 21 '16 at 21:02
1

Apparently this was a known issue and was released with Spring '16 for the Salesforce1 App and details can be found on https://success.salesforce.com/issues_view?id=a1p30000000jYhZAAU

However, there is still a known issue with new tabs in the browser version of Lightning that is scheduled for Summer '16. https://success.salesforce.com/issues_view?id=a1p30000000eXeWAAU It still generates a link, but loses the Lightning nav/header.

HYPERLINK("/apex/MY_VF_PAGE","View My Page")

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.