I am designing a dashboard using Einstein Analytics. The dashboard has come very far with change in multiple dataset widget. So, before retrieving the dashboard using sfdx, I was cleaning up unused lenses from the Query panel. Once particular lens is listed as Queries with Errors.

enter image description here

I have tried to delete this from the dashboard but if I click on delete the whole page goes blank. I click on view Error and it shows the following

enter image description here

So, I tried to break into the JSON of the dashboard, searched for the lens_1 section of the JSON, cleared it and and tried to re-depoy it to the org to which I am getting this error.

enter image description here

I have also tried deleting the dataset itself. But, the dataset cannot be deleted as long as it's lens is used in Dashboard. Is there any other way I can clear this lens from the query section??

2 Answers 2


I have faced this on a couple of occasions. It is, indeed, a nuisance (i.e. a bug, IMHO) that anytime a query is in error you can't delete it via clicks (at least for me the dropdown doesn't even display other options other than View Error).

What I've always done is actually as explained in the question: open the JSON and make sure you delete the query as well as anything else that depends/uses it. That has worked for me.


I am also facing this issue, any help from Developers or Salesforce employees would be grateful.

Please suggest

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .