0

I am having trouble working with CLI on VSCode. I think there was an Visual Code update which i did and after which VScode and apex integration stopped working.

Looking at the VSCode console gives the foll error

Activating extension 'salesforce.salesforcedx-vscode-core' failed: Cannot find module '@salesforce/salesforcedx-utils-vscode/out/src/i18n'

Require stack:

  • c:\Users\Pradip.vscode\extensions\salesforce.salesforcedx-vscode-core-48.6.0\out\src\messages\index.js

  • c:\Users\Pradip.vscode\extensions\salesforce.salesforcedx-vscode-core-48.6.0\out\src\channels\channelService.js

  • c:\Users\Pradip.vscode\extensions\salesforce.salesforcedx-vscode-core-48.6.0\out\src\channels\index.js

  • c:\Users\Pradip.vscode\extensions\salesforce.salesforcedx-vscode-core-48.6.0\out\src\index.js

  • c:\Users\Pradip\AppData\Local\Programs\Microsoft VS Code\resources\app\out\vs\loader.js

  • c:\Users\Pradip\AppData\Local\Programs\Microsoft VS Code\resources\app\out\bootstrap-amd.js

  • c:\Users\Pradip\AppData\Local\Programs\Microsoft VS Code\resources\app\out\bootstrap-fork.js.

Version: 1.43.0 (user setup)
Commit: 78a4c91400152c0f27ba4d363eb56d2835f9903a
Date: 2020-03-09T19:47:57.235Z
Electron: 7.1.11
Chrome: 78.0.3904.130
Node.js: 12.8.1
V8: 7.8.279.23-electron.0
OS: Windows_NT x64 10.0.18362

Above is the VScode version details

I tried uninstalling and reinstalling the extension but still the same result

2
  • 1
    I am on the same release but I dont have this issue. Maybe you can check the installed modules. If I see the release page, then it does have this folder. Maybe you can verify it once manually by navigating to the path. github.com/forcedotcom/salesforcedx-vscode/tree/release/v48.6.0/…
    – manjit5190
    Mar 14 '20 at 9:12
  • I couldnt find the folders either. i am going ahead and reinstalling VS Code
    – Prady
    Mar 15 '20 at 5:26
2

This worked for me (without uninstalling VS Code):

  1. Uninstall Salesforce Extension Pack from VS code extensions
  2. Delete all salesforce related folders under the vs code extensions folder, you can find them in:

    Windows %USERPROFILE%.vscode\extensions

    macOS ~/.vscode/extensions

    Linux ~/.vscode/extensions

  3. Install Salesforce Extension Pack back again

3
  • How has the extension worked since you did that? Do you have to uninstall/reinstall each time you open a Salesforce project? Oct 26 '20 at 15:57
  • 1
    It only failed that one time. Has been working fine ever since
    – Ideasforce
    Oct 27 '20 at 18:13
  • 1
    Thanks! Yeah, it seems to be working well for me, too. Thanks for posting that solution! Oct 28 '20 at 3:45
1

I finally ended up reinstalling vscode. Uninstalling VS Code doesnt remove the extension folders. I went ahead and deleted all the folders related to salesforce in the extensions folder and then opened VS Code and reinstalled the salesforce extensions as well.

Everything is back to working condition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.