1

I'm attempting to retrieve metadata from my sandbox org in order to deploy to production. I've been doing this over the past month or so using the following commands in my VSCode terminal:

export SFDX_MDAPI_TEMP_DIR=~/Dropbox/vscode_workspace/....
sfdx force:source:retrieve -m ApexClass:Apx_Test

I then look in the dir that was set in the first command, and see a nice package with the class listed in the second. I take the name of the folder, and deploy as follows:

sfdx force:source:deploy ... -u myProdAlias

This worked perfectly until today. Now when I run the force:source:retrieve, I see the package folder, but when the command finishes running, the folder is deleted!!

Has anyone else seen this behaviour? I tried it on a couple of my projects to verify it wasn't just an org setting and got the same results.

0

This seems to have been resolved with an updated to VS Code.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.