0

VSCode crashed (kept timing out when I tried to push) so I force quit and restarted my Mac. After restart, I opened VSCode and it has saved all my changes, but...

  • the scratch org doesn't appear down in the app footer where I usually can click to open it -- though it "knows" its default scratch org because I can do the sfdx force:source:push command in the terminal and it works
  • I can't use Shift-Command-P to access the push command. The only sfdx commands in the command palette are Create Project, Create and Setup Project for ISV Debugging, and Create Project with Manifest. These are the commands you get before starting a project -- but my project is open in the explorer.

Anybody know how I can "reset"?

MORE INFO


This is the case no matter which project repo I open. So it seems app-level rather than project level.

I tried disabling the Salesforce Extension Pack, restarting the app, re-enabling the Salesforce Extension Pack and reloading the window. No bueno.

Under normal circumstances, when you're starting a new project, the SFDX commands in the command palette are the ones I'm getting now... all about starting a new project. But then when you have a project, the palette commands change to include the full set of sfdx commands. What "tells" VSCode that info?

First I was thinking some file in my project was corrupted, but I'm getting this issue on all my projects, so I suspect something is wrong with the sfdx extension.

The CLI still works fine (including in the integrated terminal window in VSCode), just not the integration into VSCode command palette.

YET MORE INFO


Even the few sfdx commands that do appear in the command palette don't work. I get an error command 'sfdx.force.project.create' not found

LATER... I opened a new VSCode window and ran the SFDX: Create New Project command, and it worked to create a new project. However, once the new project is created, I would expect the expanded set of SFDX command to show up, but they don't.

  • If you rm -r the .sfdx folder inside your project, does it avail you? – David Reed Feb 9 at 2:17
  • Wouldn't rm -r wipe my entire project? – PatMcClellan__c Feb 10 at 17:44
  • It would if you ran it on the project folder; I was suggesting only deleting the .sfdx cache folder. However, your edit suggests that's likely not the problem. – David Reed Feb 10 at 18:31
  • I've uninstalled the Salesforce Extension Pack, restarted the app, re-loaded the Salesforce Extension Pack. Still no good. – PatMcClellan__c Feb 10 at 18:36
0

When I uninstalled VSCode, then reinstalled and opened the app, it knew to open the project that I had most recently worked on. That told me that uninstalling wasn't really clean. I was dumping the app from the Applications folder, as well as the .vscode/extensions folder, but there had to be more. That search led me to this thread.

I deleted all those files, did a fresh install, reloaded the Salesforce Extension Pack, and now it works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.