14

I have an object that uses a formula field to display an image and the Search Layout for the object Tab includes that image formula field. The images display fine in Salesforce Touch, but with Salesforce1 the formula itself is displayed, not the image. Note that this problem doesn't seem to occur on other list views, just the Search Layout associated with the Tab. Are there any workarounds to make the images show up in Salesforce1 like they do in Touch?

This is an example of where to find the Search Layout for the object Tab, which is the view causing problems:

Search Layout option for Programs Tab currently does not have the formula field added.

Example through iOS app of the image formula not working:

img tag is escaped

  • Noting again that this problem doesn't occur on other list views, just the Search Layout associated with the Tab view. – snugsfbay Dec 16 '13 at 17:26
  • are you facing the same problem when using mobile browser? – Sindoora Dec 18 '13 at 9:26
  • Sindoora, More info can be found in Daniel's reply below where he reproduced the problem in various scenarios. Above is an image of what I get through the iOS app, but in Safari, I don't see anything other than product code, no image and no image formula. And, as I mentioned, some list views do try to display part of the image, but the Tab layout does not. – snugsfbay Dec 18 '13 at 13:03
5

I suspect this is a bug in the Salesforce1 iOS app and that the image formula fields are not supposed to display in this layout at all. This is based on:

  1. the other devices not showing the link at all, and
  2. the value being incorrectly HTML encoded in the iOS version, and
  3. any other selected fields on the layout not displaying. In my example below the Company and Phone fields don't appear on any device. Perhaps only the Name field is supposed to appear.

I did a test and my images appeared in the Salesforce1 search layout.

  1. Created a test formula field on Leads with the following formula: IMAGE("/img/seasonLogos/2014_winter_aloha.png", "Red")
  2. Added the field to the Selected Fields of the Leads Search Results layout. I had to include it in the first four fields as
    ...Salesforce1 search results show only the first four fields from an object’s Search Results layout
    Source
  3. Tried searching for John via /one/one.app in chrome. The image appeared (although cropped). Salesforce1 from Chrome
  4. Tried the same thing from my phones browser. It appeared, but was also cropped as well Salesforce1 from Nokia Lumia 920

So it would appear at the most basic level the Salesforce1 Search Results page will display images from formula fields.

The issue might be the specific image link that the formula is creating. Possibly in combination with how Salesforce1 is being viewed (I.e. native iOS or Android app). Historically I've seen browsers include the intended image URL as a placeholder when the intended image couldn't be loaded.

What does the HTML source look like for the problem page? In particular, is Salesforce rendering image tags?


As you have noted, when using a browser directly only the Name field will appear on recent items regardless of the Tab Search Layout.

Tab Search Layout won't render any additional columns.

Here is my Lead Tab Search Layout.

Leads Tab Search Layout

As the same layout appears in the iOS Salesforce 1 app. iOS Salesforce1 showing HTML escaped Images

  • Thanks for your input, Daniel! Here is a link to what I am seeing through the iOS app: twitter.com/snugsfbay/status/408834624337354752 but in Safari, I don't see anything but the product code, no image and no image formula. And, as I mentioned, some list views do try to display part of the image, but the Tab layout does not. – snugsfbay Dec 16 '13 at 1:45
  • It is also worth noting that the search list view you have in your example does not work for me in the iOS app, but does try to work in the browser window using Safari! (I say 'try' because the pic is trimmed to maybe 10-20 pixels high. – snugsfbay Dec 16 '13 at 1:56
  • @snugsfbay from your example image it appears that Salesforce is HTML escaping the image tag. Out of interest, which layout needs to be modified for the field to appear in the recent items list? I tried adding it to all possible search layouts and couldn't get it to appear in any form. – Daniel Ballinger Dec 16 '13 at 19:06
  • I added another image to the question to indicate where the search layout is for the Tab. And I just want to restate that the behavior is different between Salesforce1 in a Safari browser window and the Salesforce1 iOS app. The former shows nothing where the image should be, the latter shows the image formula. – snugsfbay Dec 16 '13 at 19:25
  • @snugsfbay Ah, I understand now. I had put my image field on the Leads Tab Search Layout, but it doesn't appear in the web browser version. I'll try and find an iOS device to try it from. – Daniel Ballinger Dec 16 '13 at 20:13
0

The solution, as it turns out, is to use Flexipages. They have their own problems and limitations, but for list views, they can at least support small graphics. For more information, you can see my write up here: http://www.snugsfbay.com/2014/04/provide-mobile-users-with-rich.html

View incorporating graphics

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.