8

We have several Tabs overridden by Visualforce pages. Ohter Visualforce pages are reached via a Link.

Until Summer 18 as default all these pages were rendered with Header and Sidebar. So on most of the pages, I did not use the attributes showHeader and sidebar on the apex:page

Now starting today, the Headers and Sidebars are missing. I've already tried to set some attributes explicitly on the apex:page

<apex:page standardController="MyCustomObject__c"extensions="MyApexExtension" showHeader="true" sidebar="true" standardStylesheets="true">

Also I made sure, that I'm not in Lightning-Experience-Mode, by switching to LEX and back to Classic using the Switcher under MyName ==> Switch to...

So whatever I set for these attributes and after double-checking that the user is in Classic-Mode, the pages are rendered always without Header and Sidebar.

Is there any way to get the pages redered with header and sidebar again?

Update

I found a very desperate workaround to get rid of the sidebar and header amputation by Summer 18 by completely turning LEX off. This global kill-switch is NOT what I want and can IMOH only be an intermediate solution.

So in parts @sfdcfox is right: the system thinks that I'm in LEX. Only that I'm not and LEX is just not disabled. For me, it looks like a bug of Summer 18. I'm not sure if support would classify this as an developer issue which would prevent me for logging a ticket for this possible bug.

  • I believe it depends if the system currently thinks you're in Lightning or not. Did you try switching to Classic? – sfdcfox Jun 11 '18 at 9:20
  • @sfdcfox yes, that was my first try. Switched to LEX and back to Classic using the default standard switcher, wich Salesforce provides under "YourName" ==> Switch to - unfortunately with success – Uwe Heim Jun 11 '18 at 9:22
  • I noted a weird thing, I uses Organizer chrome extension to log into orgs, I switch to lightning experience in one of my org, log out from org, then again log in with Organizer....It logs me into classic and now if i open any VF tab it don't show header,sidebar etc.... – Mr.Frodo Jun 11 '18 at 11:36
  • 1
    Ive gotten this now that they've decided to start enabling LEX automatically even if you have it set to classic. Once you switch back to Classic it looks correct. Even if you enable LEX manually it looks correct, its only the initial login when they auto-enable it. – Phil B Jun 18 '18 at 14:02
  • 1
    @PhilB yes, it's related to the auto enabled LEX, but it's not correct the way it is. It's a bug which disappears after toggling on/off LEX on the profile. – Uwe Heim Jun 19 '18 at 6:06
2

In your comments you suggest that you can work around this by turning LEX off for the org, but I found that removing the LEX User permission from the profile will also fix the rendering of the header and sidebar. Then, when the LEX User permission is turned back on, the header and sidebar remain on the VF tab. It seems to maintain the header and sidebar even when switching to lightning and then back to classic.

  • 1
    yes, I can confirm, this turn off and on in the profile settings is actually fixing the issue. IMOH this is a serious bug and should be fixed by Salesforce. – Uwe Heim Jun 12 '18 at 16:52
1

Could you please log a case with the steps to reproduce? I tried reproducing this in my org and it seems to work as expected, i.e header and sidebar shows up in Classic even without explicitly setting showheader and sidebar to true.

Edit - Are you seeing this issue only on a specific browser? Or is it across different browsers?

  • Using Chrome, newest version. This is not reproducible, hence no steps possible. It just "happend" in a way that it worked last Friday and Monday it was broken (by Salesforce). The issue must be related in an error in the profile combined with the Salesforce effort to push users from Aloha to LEX. About the case: I lost uncountable hours logging cases for bug, which got closed immediately by the support stating that guys like me without Premier Support won't get Developer Support. So out of frustration I stopped logging cases. Instead im posting here. – Uwe Heim Jun 13 '18 at 17:10
  • (repro fragments) I followed @BenKean's Answer turning LEX on/off on the profile, that fixed it. I can't get the error back. So it MUST be something on the profile. – Uwe Heim Jun 13 '18 at 17:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.