0

I have received both Grumpy and Bashful Oracle error messages for a Web-to-Lead form that won't create the Lead. I have created a case, and notified my AE; however, I am desperate for a solution or work around in the next hour or two. I am updating Java, and hoping that works. I have changed the form action to be 'ap4.salesforce' instead of 'www.salesforce'. I'm not sure if encoding would have anything to do with it. It is currently set to UTF-8. This is my most recent error:

Salesforce could not create this lead because of the reason listed below. We will try creating the lead again. For more information about this error or help with Web-to-Lead, please contact Customer Support.

Reason: Your Lead could not be processed.
common.exception.SfdcSqlException: ORA-20025: 
ORA-06512: at "GRUMPY.CACCESS", line 2486
ORA-06512: at "GRUMPY.CACCESS", line 589
ORA-06512: at "GRUMPY.CACCESS", line 670
ORA-06512: at "GRUMPY.CTASK", line 552
ORA-06512: at line 1


{call cTask.insert_tasks(?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)}

{call cTask.insert_tasks(?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)}

Lead Capture Page: Not available.

Record Information: (replaced with XXXX)

Submit = Submit 
accountid = XXXXXXXXXXXXXXXXX
city = lasdf 
country = Australia 
email = work@work.com 
encoding = UTF-8 
first_name = Jackie 
last_name = Please Work 
mobile = 0412121212 
oid = XXXXXXXXXXXXXXX
ownerid = XXXXXXXXXXXXXXXX
priority = Normal 
state = VIC 
status = Completed 
street = 12 work st 
subject = Delivery Registration 
zip = 8765 
  • 1) Did you enable debug log for the W2L event to see if the Lead even makes it to Salesforce? (2) try selective reduction and reduce the # of fields on the form to the bare minimum to see if that works, then add back fields 1x1 (3) accountId is not a field on Lead. Your example looks like WebToCase – cropredy May 2 '18 at 0:44
  • Thanks so much for the reply. I have created the debug log (not really sure how to read it). Or how to check if the Lead made it. I am using web-to-lead, so I have removed the Account Id, and other lines where I tried to pre-populate Task info. – Jackie May 2 '18 at 1:23
  • Debug log is showing all successes :( – Jackie May 2 '18 at 1:26
  • 1
    see also: developer.salesforce.com/page/Basic_Web2Lead_Implementation ; you need a field for company – cropredy May 2 '18 at 1:26
  • WebToLead critical URL Change: help.salesforce.com/… – Pranay Jaiswal May 14 '18 at 19:49
1

Not sure if applies to you. I started having issued with cURL lately, then I found out the url was changed from:

https://www.salesforce.com/servlet/servlet.WebToLead?encoding=UTF-8

to:

https://webto.salesforce.com/servlet/servlet.WebToLead?encoding=UTF-8

0

This is the issue since long time. I had a requirement to convert the lead when it comed via web to lead form. This error occurs when lead comes via web-to-lead form and you have a trigger to convert the lead on insert of lead. I tried to move the logic into future method, but convert method not working in future method as it says "Future method cannot be called from another future or batch", I guess convert method is itself batch and due to which its not allowed. Then I tried Queable method, but the issue remains the same.

Finally the solution for this is to delay conversion of lead either via time based workflow, process builder flow or scheduled class. Built a formula field which is basically 2 mins after the creation on lead. So using process builder, I had updated a field on lead (2 mins after created date). On update of field, trigger called to convert the lead.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.