4

When I use a Custom Label in a Lightning Component of managed package (with custom namespace), Salesforce changes the file and saves the label with the default namespace.

For example, I save $Label.mynamespace.labelName but on the server I found $Label.c.labelName

This happens despite the development tool, I tried both Mavensmate and the Developer Console, so I believe it's something of the platform.

Is it normal?

2

I faced the similar issues but what i observed was , this works fine now even inside managed package with $Label.c.labelname and there is no need to explicitly add the namespace .

The docs do not mention this but i just tested this with c namespace and it works inside managed namespace .

  • Yes, I tried and it works for me as well. So no problem in managed packages, but I wonder why... – ctrl-z Jul 31 '17 at 13:13
  • I guess its one of those things thats fixed in v40.0 and docs have missed it – Mohith Shrivastava Jul 31 '17 at 14:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.