0

I wanted to display page for public view, so i created site for that page . But page is getting load but no contact is accessible in that page. i have added image of below what i did for site setting. what else i have to set in order to display a contact for public?

Site Setting

below link i have problem to display the result. My Public link

**Edited **

Profile Access given for for Visualforce Page Profile Access given for for Visualforce Page

i have given read access also for contactPaginationProfile

enter image description here

  • public site profile should have read access to contact. – Ratan Paul Jul 27 '17 at 7:04
  • Does the site guest user profile have permissions to the contact object and records? – Eric Jul 27 '17 at 7:05
  • Where should i have to give permission for that page ? – NITHESH K Jul 27 '17 at 7:15
  • @RatanPaul I have edited more image on access i have gave for that – NITHESH K Jul 27 '17 at 7:23
  • @Eric Yes i have given – NITHESH K Jul 27 '17 at 7:26
2

So whenever we use the sites and want to display the records then we have give the page access to that site user's profile

Also we need t provide access to the object and another thing check the OWD.

If the OWD is public then it will be display the records in sites.

If the OWD is private and not shared with site users then you won't able to display the records.

  • 1
    Better served to leave private, put site user in a group, and share with group. This way you can control access internally again – Eric Jul 27 '17 at 14:33
0

@RatanPaul helped me solving answer for my question .

I missed to update OWD setting from private to public

enter image description here

Later i changed to public

enter image description here

Now my link is accessible for public

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.