0

I tried with iframe tag and passed knowledge tab url in src attribute but it does not work, when the page is run you don't see anything.

<apex:iframe src="/_ui/knowledge/ui/KnowledgeHome"/>

Error:

Refused to display https://XXXX.salesforce.com/_ui/knowledge/ui/KnowledgeHome in a frame because it set 'X-Frame-Options' to 'SAMEORIGIN'.

0

There is one feature called "Clickjack Protection" which is by default enabled in Salesforce after Winter 16 (not sure about release though). If this feature is enabled in Salesforce, you won't be able to iframe your own Salesforce org (standard) pages in Visualforce pages. There is more information present on this feature on Salesforce site, please refer following link,

Link: https://releasenotes.docs.salesforce.com/en-us/summer15/release-notes/rn_vf_clickjack_with_headers_disabled.htm

Let me know if you need any additional info and mark answer correct if this solves your problem.

2
  • what exactly do i need to change or enable? i have tried enabling this checkbox one at a time Enable clickjack protection for customer Visualforce pages with standard headers Enable clickjack protection for customer Visualforce pages with headers disabled but i'm still seeing the error which I posted in my question, – Nick Kahn Dec 12 '16 at 15:52
  • To disable "ClickJack" protection, you will need to log a case to Salesforce. We are not allowed by Salesforce to disable that security feature. We can only enable it but if we want to disable, then we will need to ask Salesforce to disable it for our org. – Tushar Kumawat Dec 14 '16 at 7:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.