2

I'm investigating how to package a Community Template. I created a test Community template (from the Napili template) in my dev org, exported it, added it to my package, and pulled all the default metadata.

In a different org I enabled Communities, Chatter, made the user a Chatter user, and created a test community based on the Napili template. But when I try deploying the package to this org I get the following errors:

1.  flexipages/Advisor_Link_Topic_Detail.flexipage -- Error: Component Access denied to component selfService:topicTrendingArticles (line 121, column 29)
2.  flexipages/Advisor_Link_Question_Detail.flexipage -- Error: Component Access denied to component selfService:topicTrendingArticles (line 86, column 29)
3.  flexipages/Advisor_Link_Home.flexipage -- Error: Component Access denied to component selfService:topicTrendingArticles (line 127, column 29)
4.  flexipages/Advisor_Link_Article_Detail.flexipage -- Error: The object type you specified CaseArticle is invalid.
5.  communityTemplateDefinitions/Advisor_Link.communityTemplateDefinition -- Error: In field: Page - no FlexiPage named Advisor_Link_Article_Detail found

The first one says that the Topic Trending Articles component cannot be accessed. But I see it's there if I go to the Community Builder for the test Community I created. And I don't see any setting to enable it. Is there any configuration of any sort that is necessary to make this component available?

  • Try adding access="global" to all the components .Most of issues might be due to that – Mohith Shrivastava Nov 1 '16 at 16:03
  • @MohithShrivastava topicTrendingArticles is a standard component that was already in the org. I did not create it, did not get pulled down when retrieving the metadata, and I don't see any way to change its properties. – ceiroa Nov 1 '16 at 16:15
  • Advisor_Link_Topic_Detail is this your custom builder page ? Note that try to assemble only the custom components in that page – Mohith Shrivastava Nov 1 '16 at 16:24
  • 1
    Ok, a coworker gave me solution (so I won't answer it myself to get extra points): you have to enable Knowledge at the org level. Just making the user that is deploying the package a Knowledge user is not enough. – ceiroa Nov 1 '16 at 16:38
  • answer that as that helps the community looking for this error . – Mohith Shrivastava Nov 1 '16 at 16:39
2

A coworker gave me solution: you have to enable Knowledge at the org level. Under Setup > Customize > Knowledge > Knowledge Settings. Just making the user that is deploying the package a Knowledge user is not enough, but you need that user perm enabled to be able to enable Knowledge at the org level.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.