3

Created an object and I need to add a search layout for this object. But the search layout option itself is not visible for this object.

I created some more object but there is no issue with other objects.

Please help how can I add search layout here?

  • 1
    I think the presence of a tab that is at least available or visible to required to edit the search layouts. – Prajith May 3 '16 at 7:11
  • 1
    Only the Custom Objects that have their own tab are included in search results. – Prajith May 3 '16 at 7:13
  • Yes, the object I have created is custom object only. – Neeraj May 3 '16 at 8:49
  • I have tested by creating 2 custom objects: 1. allowed tab to be created and it has search layout. 2. Didn't launched tab and search layout is not available. – Neeraj May 3 '16 at 8:58
  • So I guess creating a tab will resolve your issue. – Prajith May 3 '16 at 9:23
2

It can be enabled by opening the Object in Edit mode and Tick the checkbox that says Allow Search

Go to this link for step by step approach :

http://www.srinivas4sfdc.com/2016/01/how-to-enable-search-layout-section-for.html

As we already know that once you have created any new custom object ,in the custom object detail page you will be seeing an section called Search Layout.But from Winter 16 releases for newly created objects you might not be able see the Search layouts section. because from winter 16 for newly created objects Search Layout Section will not be enabled automatically.Why is it?

Allow Search Feature

  1. Salesforce has introduced a new feature in winter 16 called "Allow Search "to disable or enable Search layout for a particular custom object

  2. By using this feature you can improve the performance of global search/Side search by excluding unnecessary custom objects from search results

  3. At the time of custom object creation you need to choose whether you want to enable or not.

  4. If you want enable or disable follow below steps

    • Goto Setup--->Objects--->Custom Objects
    • Open the custom object for which you want to enable
    • Goto Search Status and select allow search to enable or deselect to disable
    • Go and observe the Search Layouts section in object detail page

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.