0

I have created a VF page in two of my salesforce Org. The VF page is used as a SOQL Query Tool. On running the query on the VF page I am receiving the error:

No such column '#field name ' on entity 'Account'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

The field that are giving me error are Jigsaw, JigsawCompanyId, AccountSource, SicDesc on the Account object

However things are working fine on the other sandbox account with the same VF page.

Is there any extra permission that need to be given.The query works fine on workbench

1

This issue is almost certainly caused by Field Level Security. Click into each field and click the Set Field Level Security button. Then make sure Visible is checked.

Also make sure you Set Up Data.com Users.

4
  • It works fine on another network , However it gives me the error on my side is there any network or security issue that may cause this Mar 14 '16 at 17:21
  • @cloudlover Your FLS settings can vary from org to org...did you check that it is indeed visible in the org that is giving you trouble?
    – Adrian Larson
    Mar 14 '16 at 17:29
  • Yep Its visible and its default system admin profile. One thing more the functionality is working fine on salesforce support end. Mar 14 '16 at 18:42
  • @cloudlover Added another link you may find helpful. Please make sure you have followed those steps.
    – Adrian Larson
    Mar 14 '16 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.