0

I'm working on a React.js web app that leverages GraphQL for accessing a combination of varying endpoints, including our org's SF data. My only issue is isolated to my Salesforce progress. In general, it's an OAuth connected app with full access permissions. I've managed to get everything wired up and using the 'GraphiQL' interface, I have the ability to successfully query Salesforce standard and custom objects. However, the only fields that seem to return any data, (from any of the objects), are 'Id' and 'Name'. All other fields, standard or custom, return 'null'.

I have a version using NForce and another using JSForce, both return the exact same result. API access is selected in System Permissions. I've tried numerous profiles including my own admin account. I've ensured that all permissions I can find (field level, object, etc.) have "View All Data", "Modify All Data" and anything API related is selected. I'm a Frontend Developer with halfway decent admin skills, but apparently not deep enough to figure this one out.

I've scoured the googles, but there is very little reference material using this combination of solutions and any related help is scarce. At this point, I'm just spinning my wheels and I'd very much appreciate any assistance. Thanks in advance.

  • Not enough for an answer, but have you looked for a "wsdl" file anywhere in your setup? There's two different APIs, and if you're using the the Enterprise version, it would need to be updated for your org's fields. – sfdcfox Jan 30 at 4:50
  • Apologies for a rather vague question and not replying sooner sfdcfox. I got lost down a hole while in the middle of a project crunch. @luqman-hakim -> The issue ended up being a matter of upper / lowercasing. As always, SF is sensitive to case, but while querying in GraphiQL, (using proper SF casing), I finally realized that I was getting a null value for anything with caps in the api name. in GraphQL, I re-created my schema/root/queries using strictly lowercase across the board and <poof> queries started populating results. Hope that helpful somehow. Thanks for the time and attention. – SeanDev Mar 13 at 4:42
0

I was caught up with the same thing too.

Let's get to the root of this. I'm really foreign with GraphQL, but from the brief google look up, it seems like a simple request/retrieve for your website data.

From my previous problem, I cant access the data due to Jade couldnt comprehend the data retrieved from Salesforce.

My solution was I changed my engine-template from Jade to EJS.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.