2

We are currently using Financial Services Cloud. When we go to the Account objects through the UI, there is the field Parent Account with API name ParentId.

When I described the Account object through Workbench or look at the generate WSDL the ParentId doesn't exist for the Account object.

Basically, if we try

SELECT ParentId FROM Account

we get the error:

select parentid from account
       ^ ERROR at Row:1:Column:8 No such column 'parentid' on entity 'Account'. If you are attempting to use a custom field, be sure to append the '__c' after the custom field name. Please reference your WSDL or the describe call for the appropriate names.

I tried the same query in a Dev org, and it worked just fine.

In the Setup -> Account settings, "Show View Hierarchy link on account pages" is enabled.

What am I missing? I believe this must be a very simple "thing" I'm forgetting here.

Googled a bunch and couldn't find anything :(

5

You almost certainly need to fix your Field Level Security. Make sure your user has Read access.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.