0

The documentation at https://developer.salesforce.com/docs/atlas.en-us.lightning.meta/lightning/components_config_for_flow_screens.htm says that if a Lightning Component implements lightning:availableForFlowScreens it should be visible in the Cloud Flow Designer, but it isn't.

This is the component:

<aura:component description="FlowCmp1" implements="lightning:availableForFlowScreens" access="global">

    Oh haiii

    <lightning:button onclick="{!c.doTheThing}"/>

</aura:component>

({
    doTheThing : function(component){
        var navigate = component.get("v.navigateFlow");
        navigate("NEXT");
    }
})

Pls help!

1

Wait, never mind! I've got it working. There were two things I hadn't done:

  • Go to Process Automation settings and check 'Enable Lightning Runtime for Flows'
  • I was looking at the wrong part of the designer - I assumed it would be part of the main palette but its one of the fields you can add under a Screen. I am a total goose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.