1

I'm trying out Salesforce 1 but I can't show the layout that I created to mobile. How can I associate this layout to make it visible in mobile?

4

You need to associate the layout to the user profile that you would like to use it. If the layout is global use: Publisher Layout Assignment if the new layout is related to an specific object use the Page layout assignment for that object. Hope it helps. Let me know if I can help with anything else :)

| improve this answer | |
  • I have created 2 page layouts for desktop and one for Salesforce1, but what Salesforce1 is showing is the same as the desktop. If I associated the desktop page layout to the profile, I only see the mobile fields on desktop. How can I have both page layouts working on the matching system? – Tiago Dec 6 '13 at 10:32
  • 1
    Hi Tiago, I'm afraid that it is not possible to have different layouts for same user, same object dependent if you are in mobile or desktop. To do that you will need to use VF pages , sorry for the bad news. Once you assign a layout to a user the same layout is applied to desktop view and mobile. – Carolina Dec 6 '13 at 10:49
  • I read salesforce1 guide to create publisher action and i I can not appear to me in Mobile – Tiago Dec 6 '13 at 11:23
0

Do you mean in your last question that you can't see the action in the layout when you create it? When you create a Publisher Action, this action needs to be added into the layout global or override the global layout for the selected object. The creation of the action only doesn't show it on the layouts, you need to physically go to the layout and add the quick action into it.

| improve this answer | |
0
  1. Make sure Chatter and the Chatter > Publisher Actions settings are enabled.
  2. Create your action (either global or in the object context).
  3. Add the action to a layout: Chatter > Publisher Layouts for the Feed page, or to the object page layout for an object's record. If you are adding it to an object, make sure that Chatter Feed Tracking is enabled for the object. Chatter Feed Tracking is not enabled by default for custom objects.

You didn't indicate whether it was a custom object or not, but it sounds like the feed tracking might be your problem if you have added the action to the page layout.

Another thing you might want to check if you have multiple page layouts is that you added your action to the layout you're actually viewing -- check the record type and/or profile.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.