5

I have a VF page on my Dev org that calls out to a 3rd party to get some JSON results. This page worked fine last night, this morning I started getting an odd error

enter image description here

But my page doesn't have any iFrames. To test this further I stripped out the page and created a very simple VF page and Controller that are about as simple as I could think of

VF

<apex:page controller="Test1Controller" >
    <apex:form >
        <apex:pageBlock>
            <apex:pageBlockButtons location="bottom">
                <apex:commandButton value="Submit" action="{!Save}"/>     
            </apex:pageBlockButtons>
            <apex:pageBlockSection title="Case" columns="1" >
            <apex:inputText label="Name" value="{!inputText}" id="myInput"/>
            </apex:pageBlockSection>
        </apex:pageBlock>
    </apex:form>
</apex:page>

Controller

public class Test1Controller {

    public String inputText         {get; set;}

    public PageReference Save() {
       return null;
    } 
}

This simple page is still getting the same error when I look at the console. What's going on here?

enter image description here

EDIT

Using Google Chrome (version below)

enter image description here

  • What browser are you using? Chrome? – BarCotter Oct 25 '13 at 11:17
  • Sorry, yes should have mentioned that. Chrome. Added the version to the question – Chris Duncombe Oct 25 '13 at 11:18
  • Most likely its chrome causing this rather than your code. If you test with another browser the issue shouldn't appear. – BarCotter Oct 25 '13 at 11:20
  • Try with setting showHeader="false" standardStyleSheets="false" @Dunc44 – Ashwani Oct 25 '13 at 11:21
  • Problem is not in your code. It is from Salesforce. Reason is known to me but no solution. – Ashwani Oct 25 '13 at 11:23
7

This is not a SalesForce error. Your page and controller look fine and are not doing anything unusual.

swappedout:// is an internal implementation detail in Chrome that is not supposed to be visible to end users

From: https://code.google.com/p/chromium/issues/detail?id=143155

Next Steps

Test out your app on another browser to verify that its a Chrome issue

There seems to be a lot of people having this issue when using Proxies or VPNs. So try looking there first.

There is also some mention of plugins causing this issue so try disabling all plugins that you are not using.

And let us know how you get on. We have a lot of users on Chrome and I would be interested in the cause of this.

  • VERY ODD. So I took your advice and disabled all my plugins, and restarted Chrome. It worked, no error. Now, I have reenabled all the same plugins, and restarted Chrome, it still works. No errors. Im stumped. Very weird, but thanks for the help. – Chris Duncombe Oct 25 '13 at 11:41
2

Problem is from Chrome browser or Salesforce. And reason are their javascript execution on the vf page which has issue with Salesforce and Chrome. In first snapshot it clearly visible that one of the javascript from Salesforce side or from browser side (browsers also have their some house keeping scripts/CSS) is trying to passing messages between unmatched url origins.

As it is not possible to pass message as because of browser security feature. A question already been asked here.

One of the possible workaround can be is make the page minimal. Means set header to false, same as with style sheet property. Also try with applying "applyBodyTag=true" and "applyHtmlTag=true".

Here this reason is caused because:

A javascript file named "VFMetadataReceiver.js" is trying to access in frame from unmatched protocol "swappedout://". It is unexpected and I believe it is not related to salesforce as i found this issue with Chrome browser on google code here https://code.google.com/p/chromium/issues/detail?id=17325.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.