1

Background: Our community was always designed to be private - but community builder lacked functionality that allowed us to select individual access settings for every page or the builder site as a whole PRIOR to Winter '17. This meant we couldn't use Community Builder to adjust access permissions, or get users pushed to our branded community builder login page.

Ultimately, we ended up accessing Site.com studio (which used to be an option from the community builder menu) and we used Site.com studio settings to change the entire site to "requires authorization". This resulted in every page redirecting you to the default Salesforce login page - not ideal, since it wasn't our branded community builder login page, but at least it was secure and required login.

Now, with Winter '17, Salesforce has fixed a lot of flaws in Community Builder that stopped us from being able to make the community private while simultaneously fixing our ability to use our branded login page. I staged this all in sandbox on a new community for testing purposes, and was ready to setup production today.

Unfortunately, it appears that Salesforce removed Site.com Studio as an option from Community Builder, and I can't seem to find my way in through other means (Not super familiar with it, to be honest). This unfortunate oversight means that I can't find a way to turn off the option in site.com studio that has my entire site set to a global 'requires authorization' setting. Since this Site.com Studio "Require Authorization" is still set globally on the entire site, it is overriding all of my other newly changed settings in Community Builder.

Problem: Thus, I am between a rock and a hard place - Salesforce fixed all of the issues that I've been calling their support department about for months, but while doing so, they restricted my access to the old Site.com Studio editor which is where I was forced to setup my "workaround" login restriction prior to Winter '17. Now I can't seem to turn that option off, which means that even though Salesforce fixed everything - I can't use any of it until this global option is disabled somehow.

Question: How can I gain access to Site.com Studio for this site to disable this option? Can I access Site.com Studio for this Community Builder site through any other means? How does one usually access Site.com Studio for a Visualforce (Non-Lightning Community Builder) community? Or, am I out of luck unless I contact Support and hope that they can escalate it to someone who can turn that option off for me?

2

Navigate to Communities | Builder

Now observe the URL .Remove of all the extra parameters after domain.The URL would look like below

https://googleflowauth-dev-ed--sitestudio.ap1.force.com/

This will open the site.com Studio for you using builder .

  • Thank you so much! Life saving information right here. Not sure why they removed our access link but glad to have an easy workaround. – Morgan Marchese Oct 22 '16 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.