15

I believe this applies to the direct Apex access to parts of the Metadata API. My impression is it prevents any old random installed package from using the new functionality to then deploy further Metadata without your permission. To make clear, deploying (some) metadata from Apex in certified packages is also supported--in fact, it's the primary use ...


12

You don't include the "extension", but instead specify it exactly as you would in package.xml: Metadata.layout attachmentLayout = new Metadata.layout(); List<String> layoutList = new List<String>{'Account-Account Layout'}; List<Metadata.Metadata> components = Metadata.Operations.retrieve(Metadata.MetadataType.Layout, layoutList); ...


8

Nope, you can't request a Summer 17 org at this time. The version is controlled during the new release preview. Generally, depending on the pod your sandbox is on, you must either refresh during a certain window, or not refresh during a certain window. This release's refresh window has already happened, but for future releases, make sure you subscribe to ...


8

There can be several reason of this deployment error. Possible reason is mandatory field is missed or the referenced metadata name is incorrect. Below is the working code to create and update Custom Metadata via Metadata namespace. Callback class:- public class CustomMetadataCallback implements Metadata.DeployCallback { public void handleResult(...


6

By fully retrieving all permissions all the time, it will avoid the various Bad Things that happen when you only retrieve a partial package. This would lead to the XML file spuriously growing very large/small simply based on how the tool you're using decided to retrieve your org's metadata (e.g. a partial retrieve would result in a partial permission set, ...


6

This looks like an issue with Summer 17. I've been able to replicate it in a sandbox. After some "fun" debugging it, here's what I found. There is a call to /ui/support/servicedesk/servlet/ServiceDeskServlet that is done to determine whether or not to build a workspace. It looks like if the URL is a standard URL, it does something different than if it is a ...


5

This is a normal behaviour - LS in V40 uses native Proxy object. https://developer.salesforce.com/docs/atlas.en-us.208.0.lightning.meta/lightning/security_proxy.htm https://developer.salesforce.com/docs/atlas.en-us.208.0.lightning.meta/lightning/security_global_access.htm


4

For anyone who may find this later. The solution was to use jquery-3.2.1. jQuery 2.2.4 seems to try and modify the DOM outside of its scope.


4

Update: Issue seems to be resurfacing, cf here: I Install Managed Package Into Sandbox Fails on All Lightning Component Bundles This probably is the known issue that has been mentioned by Daniel Ballinger, the OP, and has been reported as fixed this weekend. https://success.salesforce.com/issues_view?id=a1p3A0000008jMrQAI Your request to install ...


4

Alright - Suuuuper hacky, but I found a way. There is some code in keyComboProcessor.js _isEditingText() that checks a few ways the user could be editing. If you match these with your focused element you can sneak around the handler. _isEditingText:function(keyboardEvent) { var targetElmt = keyboardEvent.target; if(targetElmt.tagName === "INPUT") { ...


3

As far as I know (though looking over the Winter '18 release notes, which mentions that this critical update will be enabled for everyone as part of that release), the critical update you mention is only to allow you to set up CSRF protection on GET requests on a page-by-page basis (It shouldn't automatically turn that on for any existing page). That option ...


3

This issue has been previously reported. (MS Edge) Error when accessing window.location in lightning components with LockerService enabled The cause is a MS Edge bug, we have filed an issue for the MS team. https://developer.microsoft.com/en-us/microsoft-edge/platform/issues/12112572/


3

This specific issue for Node.contains() and a few other Node APIs are currently scheduled to be fixed in the .3 patch. Of course, this can be delayed if any issues are found with the fix but things are looking on track so far. Thanks again for detailed bug report and initial debugging.


2

Here is what I infer from the email and my experience with salesforce metadata API Permission set does not have API version tied to it in the metadata XML file .So the question on how do I determine the version of permission set ?It is the version of package.xml that we must be aware of . So lets answer the queries 1.How can you determine the API version ...


2

did you check your orgs email deliverability: Setup -> Email -> Deliverability it needs to be set to All Email, for the email action to be visible cheers ian


2

In JavaScript, each Proxy() instance has its own identity different from all other Proxy() objects and from the object proxied. When applied to two objects, he equality operators == and === compare the object references, and the consequence is that: Comparing distinct proxies returns false even though the underlying target is the same. An unwrapped target ...


2

This now appears to be working in Winter'18. I have confirmed through a helper library i am developing (WIP here) to make things a little less abstract and more DML-like when working with custom metadata records. Its still WIP, i will update my blog, andyinthecloud.com when its done. Meanwhile a snippet of its use is shown below, i will also be including ...


2

In Summer 17, there are two issues that will affect you: Locale has been removed from all localizationService calls. The locale parameter is deprecated for several methods in the AuraLocalizationService object. The validation for the locale parameter has also been tightened to allow locale values to match only the user’s Language or Locale settings in ...


1

This is a bug in ltng:require. Locker Service is not supported in IE11 and we gracefully degrade it and let the components work in non-lockerized mode. But some recent code changes were causing ltng:require to invoke locker service routines that require Proxy support and would cause the error you reported. This has been previously reported and a ...


1

Unfortunately the issue you are facing is caused by IE11. The root of the problem is that LockerService is now enabled by default since Summer '17 and IE11 is one of the few browsers that do not implement required security standards. The official recommendation is to use another browser than IE11: IE11 doesn’t support CSP, so we recommend using other ...


1

Hi @pasan Eeriyagama i got reply from Salesforce. They have appiled a Patch and problem is resolved. So pages are working on Summer 17 preview.


1

To answer your immediate question, this issue is directly caused by the ui:inputDate component provided by Salesforce. It's still using the locale parameter that has been deprecated in Summer 17. The locale parameter is deprecated for several methods in the AuraLocalizationService object. The validation for the locale parameter has also been tightened to ...


1

It looks like a known issue, I have the same problem: Salesforce has posted about it here: https://success.salesforce.com/issues_view?id=a1p3A000000EAI4QAO&title=summer-17-app-menu-picker-missing-post-upgrade-ise-being-observed-when-creating-a-custom-app


Only top voted, non community-wiki answers of a minimum length are eligible