New answers tagged

0

Removing vertical-align worked for me. Thanks to the comment from @YsrShk. <template> <lightning-layout class="slds-form slds-size_3-of-3 "> <lightning-layout-item flexibility="auto" padding="around-small"> <lightning-input type="text" label="Test" ...


0

I believe the issue here is that you're using IconSettings but not including any sprites. The docs here are admittedly light, but when we've implemented this in the past using webpack, a solution was to include the sprites as symbols on the page, so they can be referenced directly in the SVGs via onRequestIconPath. <IconSettings onRequestIconPath={({name})...


0

I had the same issue on SF mobile for iPhone. The fix is to limit the viewport maximum scale to 1.0. Add the following code to your init function and this should fix your issue: //add viewport meta tag var meta = document.createElement("meta"); meta.setAttribute("name", "viewport"); meta.setAttribute("content", "...


0

Your markup is not valid because you're missing a large number of spaces. You are using two variables, isForContatct and isForContatct1, but you're setting each in one branch and failing to set the other. This means that one of your two variables is either undefined or has whatever value you default it to elsewhere in your code, both of which would produce ...


2

I know those breakpoints are also available to control the visibility with slds-hide or slds-show, but I'm afraid there aren't that many more classes supporting this. You could use these classes and create a version for each that would suit the slds-gutter of your preference, but there must be a better approach to this.


0

I had similar problem. In my case it was a picklist with long list of options. slds-modal design specifications(here) says they have not done anything to accomodate content with a dynamic height and it would always add a scroll bar. But but, there is a hack. which worked for me. .slds-modal__content { overflow: visible; overflow-y: visible; } PS:...


2

Modals are not designed to be placed inside other modals. Without seeing some sample code, it's hard to say how you'd fix this, but markup for one modal definitely should not appear within another. If you're using Aura, use the lightning:overlayLibrary to properly layer modals. There's no such equivalent yet in LWC, but you could build your own without too ...


1

You have misplaced the modal footer, in order to get proper styling you should place your modal footer at the same level as the slds-modal__header and the slds-modal__content. This is an example of how the modal needs to be structured in order to get proper formatting <section role="dialog" tabindex="-1" aria-labelledby="modal-...


0

I achieve this by doing something like this, following ChiCloud response, I try to listen to click events on my component and on document, and react based on it. Does not feel like the most optimal way since I am messing with the DOM outside my component. But all methods using onblur do not help me as I have interactions in my menu (like deleting items from ...


Top 50 recent answers are included