New answers tagged

3

Because your changeset is different from what you prepared via SFDX. Your changeset includes SetRequestOpportunityFields whereas your sfdx metadata directory includes SetPaymentOpportunityFields (for which you have no corresponding test class). That there is your entire issue. Bonus You don't need to do the conversion to metadata api form, as force:source:...


2

This is a known issue and is being worked on. The known related issue is here The way force:source:deploy works is it first does a source convert from DX Source format to the mdapi source format. Looks like this is where the bug exists that it is not reading the custom label folder and files. While the CLI engineering team works upon it, here are some ...


0

I started getting this issue as soon as my Salesforce Extensions got updated to v50.1.0 in VS Code. After returning to the previous version being v49.13.0, everything restarted working.


0

It seems some objects, applications launched by Salesforce with this pandemic. I know two apps I have seen in my org Trusted Cards and WDC(work dot com). A simple solution would be refresh the sandbox. Or you may raise a case with Salesforce to match object/licenses with Production org. The reason for error is - Org is not updated/upgraded with those new ...


0

I just updated the salesforce extensions to v50.2.0 and the issue has been resolved. I have the same error, I believe after I updated Visual Studio or Salesforce Cli I was able to retrieve the code by typing this command on the terminal: sfdx force:source:retrieve -m [MetadataType] for example: sfdx force:source:retrieve -m ApexClass sfdx force:...


0

You can rename an unlocked package with the following command: sfdx force:package:update -p package-alias -n new-package-name Full reference: https://developer.salesforce.com/docs/atlas.en-us.sfdx_cli_reference.meta/sfdx_cli_reference/cli_reference_force_package.htm


1

sfdx force:project:create -n ProjectName --manifest Right click on package.xml and click "SFDX: Retrieve Source...". You can download some resource. I have same error like this after I Re install my windows system and vscode


2

Unlocked Packages run their tests in a completely blank org, similar to creating a brand new Scratch Org, deploying your tests there, and then running them. As such, if the metadata is not in your package, it doesn't exist for the purposes of your test. There is a pilot to work around this limitation, but for now, you'll need to include the record type in ...


0

You can do it by importing a static resource with preferred css. customDatatable.js: import LightningDatatable from 'lightning/datatable'; import { loadStyle } from 'lightning/platformResourceLoader'; import CustomDatatableResource from '@salesforce/resourceUrl/CustomDatatable' export default class CustomDataTable extends LightningDatatable { ...


0

Root Cause: In my case, When I created data JSON file, My dev Hub was not configured with any namespace but after namespace configuration, I got this issue. Solution: Change data JSON files and add your namespace with every file and fields. Old Name: FileName.json and fields in the file was fieldName New Name: NameSpace__ FileName.json, NameSpace__ ...


1

You can use good old package.xml and ANT for deploying bulk of components (custom placeholder fields in your case) through a single deployment command. All the custom fields should be listed in the package.xml. Refer to this, this & this to explore this option. You can find many blogs and article related to this on the web. If you want to stick with VS ...


2

This is not full code and a pseudo-code at this point but should get you started. This also assumes its a pre-deploy hook for now. Approach 1 - Establish another session using sfdx-core lib You can use the sfdx-core library to use the keys stored in your local machine to easily establish a session. The key here is to note that argv contains all the flags ...


0

I would suggest you to rethink what you are going to deploy to your scratch org, and also not to deploy metadata that relies on the org's configuration that can not be deployed. The reason not to deploy this, in your situation, is that org wide addresses are org-specific, not project-specific. So you will face issues deploying that. You can't even deploy ...


0

Please use, proper instance URL and it'll work fine. if you use - />sfx force:org:display it will show the correct instance name( something like domain .my.salesforce.com ) along with current access token. I tried the same, and it is working fine.


0

If your are connecting to a sandbox, edit your sfdx-project.json file to set sfdcLoginUrl to https://test.salesforce.com before you authorize the org. Here's the code that I'm using { "packageDirectories": [ { "path": "force-app", "default": true } ], "namespace": "", &...


0

If your are connecting to a sandbox, edit your sfdx-project.json file to set sfdcLoginUrl to https://test.salesforce.com before you authorize the org. Here's the config that I'm using { "packageDirectories": [ { "path": "force-app", "default": true } ], "namespace": "", &...


0

Changing Scratch Org Edition to Developer from Enterprise resolved the issue.


Top 50 recent answers are included