6 votes
Accepted

Prettier errors out when formatting Apex classes

Posting this so others can find it useful: If you run into this error, make sure to update your java version to at least 11 as prettier-plugin-apex version 1.9.0 and above doesn't support for jdk ...
javanoob's user avatar
  • 8,877
3 votes

Prettier Apex Plugin Won't Format Apex

Lately, i have also experienced problem with Prettier new version. Can you try changing the devDependencies in package.json and use a previous version for Prettier plugin. "prettier-plugin-apex&...
Anshul Agrawal's user avatar

Only top scored, non community-wiki answers of a minimum length are eligible