Skip to main content
New
Stack Overflow Jobs powered by Indeed: A job site that puts thousands of tech jobs at your fingertips (U.S. only). Search jobs

Questions tagged [install]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
1 vote
1 answer
920 views

SF Package Install Warn - @salesforce/plugin-packaging different from the version specific by sf - Type Error - this.config.plugins.filter is not a fn

I am running into an issue/error when I am trying to run the sf package install command I am using the latest @salesforce/cli which is currently 2.20.6 (even tried latest nightly 2.22.1) https://www....
Erik Strudels's user avatar
1 vote
1 answer
169 views

2gp error when installing unlock package into empty sandbox: Complains re existent Email Template in unfiled-public folder

We've created first version of our unlocked 2gp package. Bunch of custom email templates have been packaged as a part of unfiled$public folder (including MyCustomPackagedEmailTemplate one). Now when ...
wesaw's user avatar
  • 3,080
0 votes
1 answer
814 views

What is the reason and resolution for package uses old Order Save Behavior?

My client asked why certain subscribers of the package I build on behalf of my client, cannot install the package. When they try to install the package, the following error appears Can't install the ...
Patlatus's user avatar
  • 17.1k
0 votes
1 answer
306 views

How to prevent the License Management App (LMA) from creating Lead records when a package is installed via an installation URL?

Is it possible to prevent Lead records from being created by the License Management App (LMA) when a package is installed via an installation URL? If package installation occurs via an installation ...
Renzo J.'s user avatar
0 votes
1 answer
210 views

How to "install" LWC?

I need to start with LWC but I used my company pc, and it has some bureaucracies to install software so I cannot install Salesforce CLI.. There's another way? Extension on Visual Studio Code works?
Alexia Ribeiro's user avatar
0 votes
1 answer
731 views

Issue with installing the SFDX CLI in Linux

I had some issues with my SFDX CLI as I was not able to use SFDX commands from the terminal of my VS Code in Linux. So I looked up on the web and as part of one solution that I found on web, I was ...
Ganit's user avatar
  • 143
1 vote
1 answer
351 views

How do I download & setup Git Bash, for Windows & VSCode?

I don't know where to get GIT Bash from and how to set it up. I am asking because the answers were not found or not obvious, install was a bit of an unknown, hence this might help someone else, so I ...
TheArchitecta's user avatar
0 votes
0 answers
44 views

Dataloader stopped working after installing Ant [duplicate]

I installed Ant and after this, Dataloader stopped working - when I run Dataloader then this window is popping out: After this, about there is line "The system cannot find the path specified.&...
NonameJavaNoob's user avatar
4 votes
2 answers
1k views

SFDX: How can I make my plugin available to install via sfdx plugins:install and a git repo reference?

We have written a plugin for use by our PS and QA teams for complex and large "data plan" loading and want to make it as easy to install for them as possible. We don't want to make it ...
Phil W's user avatar
  • 36.7k
1 vote
1 answer
167 views

Issue while installing a managed package in a production org

I have the standard Activity component in one of my custom object's page layout which has 3 activities (New Event, New Task , Log a call)in it. I created the 2GP and during installation of the package ...
Amrita Rout's user avatar
1 vote
0 answers
1k views

sfdx install fails with: Not available for deploy for this organization

I've been struggling to debug this all afternoon. Perhaps someone can help? I've created a managed package using SFDX and everything looks good. I can even promote the package. However when I try to ...
Dan Selman's user avatar
6 votes
2 answers
1k views

Upgrade unlocked package fails due to "Cannot use unfiled-public or user folders in a package"

I'm trying to install the unlocked package to a sandbox org, where a previous version of it already exists. I used to have an email template in unfiled public, but I moved it to a public read/write ...
mluecke's user avatar
  • 191
4 votes
0 answers
444 views

Package Install custom validation error - can't use template with page type AppPage

Need help resolving a package install validation error. I'm installing a managed package (containing a newly developed custom app) into a test org for the first time. I get two of the following ...
el Jeffe's user avatar
4 votes
0 answers
44 views

A delayed package install skips Post Install Script

After installing our package 10 times, it timed out installing twice and said it would email me with details of the install. It eventually installed after a few more minutes and emailed, but there was ...
Kyle Heironimus's user avatar
13 votes
1 answer
678 views

Install Managed Package Into Sandbox Fails on All Lightning Component Bundles

I have developed an app for the Salesforce platform and have successfully created a beta managed package ready for testing on one of our sandboxes. however when I try to install the package on the ...
D Woodcock's user avatar
4 votes
1 answer
3k views

Managed package and triggers

I have a managed package with a trigger on lead object. I added a trigger handler class and a trigger object. I wanted to know how does the trigger integrate with local triggers on package ...
Brian's user avatar
  • 315
-1 votes
2 answers
1k views

Don't know how to install app from github [closed]

I'm trying to install Declarative Lookup Rollup Summaries from GitHub. Can someone please tell me how to do that? https://github.com/afawcett/declarative-lookup-rollup-summaries When it's properly ...
user2616155's user avatar
2 votes
1 answer
133 views

Post install script error: Fails to find field being added in new package version

I am currently running into an issue with my post intstall script batch job. When trying to copy the values from the old field on account to the new field, for one reason or another I get the ...
Zander Millar's user avatar
0 votes
2 answers
718 views

Attempting to Install Package Using ANT Script and Getting Error

I am using ANT version 1.9.7 and Force.com Migration Tools version 37.0. Using the below script I get the error "failed to create task or type installPackage". I have not found documentation around ...
Ian G's user avatar
  • 213
1 vote
2 answers
634 views

Problem installing our manage package

Good day everyone, I have a manage package in my org. It is working well. But just this morning, when I try to install the package I've seen this error for the first time. "Something has gone wrong....
Hope's user avatar
  • 1,273
0 votes
1 answer
40 views

Prompting user for user credential right after the app installation

Is it possible to ask for user input at the end of app installation? I need users to enter credentials for external API at the end of app installation or very beginning of an app. Basically, I'm ...
June Woo Suk's user avatar
2 votes
2 answers
191 views

How to develop for an organization that has a custom field that my organisation doesn't have?

An organization I'm developing a managed package for has a custom field on their User page. Adding that field to my organization User page allows me to test my code, but as soon as I try to install ...
Alan Lau's user avatar
-1 votes
1 answer
4k views

Why can't I install this app/package in sandbox?

I am trying to install the trigger framework mentioned here When I am installing this app in my sandbox (https://login.salesforce.com/packaging/installPackage.apexp?p0=04tU00000005VdB) , It is ...
javanoob's user avatar
  • 8,887
3 votes
1 answer
552 views

Do we have Pre Install script like Post Install?

We have a app in appexchange and would like to know if there is a Pre Install script similar to post install script? The reason is our application is applicable only to organizations which have ...
shelton's user avatar
  • 31
2 votes
1 answer
1k views

How to test a Salesforce Installhandler?

I have written one class for Post Installment InstallHandler. I also have written Test class for the same which work very fine. Run successfully with full coverage. But Now, I suppose to be sure ...
Salesforce Steps's user avatar
0 votes
1 answer
249 views

Cannot Install Force.com IDE from Market or Site with Juno or Kepler org.eclipse.update.ui 0.0.0 error

After downloading eclipse after opening, select Help - Install New Software - Available Software Sites Site name: Force.com IDE location: http://media.developerforce.com/force-ide/eclipse42 ...
MeighanRocksSF's user avatar
0 votes
0 answers
39 views

Can't open Salesforce1

I install the Salesforce1 and can open the application. I have Samsung G SIII and 4.3 Version. Just appears Blue screen with salesforce1. In another device I can sign in. Can help me?
lisyy's user avatar
  • 169
3 votes
3 answers
8k views

Unable to connect to Force.com after installing IDE

I have been trying to install the latest Eclipse IDE for Force.com, but kept running into the "Invalid Api version specified on URL error". It's similar to this thread Force.com IDE unwilling to ...
Nataku's user avatar
  • 161
0 votes
0 answers
99 views

Problem building SalesForce mobile app : Android [duplicate]

I created SalesForce Native/Hybrid app as in this link. Everything is fine but when I try to run the app by importing it into eclipse, it keeps on popping main activity with following error in logcat....
Braj's user avatar
  • 349
2 votes
0 answers
222 views

Upgrade of Managed package fails with <Data Not Available> error email

When I tried to upgrade a customers org with the newest version of our managed ISV package I received this error email minutes after I finished the installation wizard: Your request to install ...
Robert Sösemann's user avatar
3 votes
1 answer
588 views

Will a 30 Day ISV Trail allow me to install an application onto a Professional Edition?

getting a bit strained from reading tons of documentation and not really knowing what to search for. I have created a Developers Force Free edition and created an application that uses Apex Classes ...
EdgeCaseBerg's user avatar
1 vote
0 answers
163 views

InstallHandler not working

I have created a product and have it as a package and try to install into new env. I have a custom setting i am trying to create records into custom setting after the package get installed but i am ...
AnuRaj's user avatar
  • 2,482
-1 votes
2 answers
490 views

insertions of record automatically while installing

I have created a product which contain a custom setting. In the custom setting it contain a record. I have the product as package and installed it into an new env but after installation the user need ...
AnuRaj's user avatar
  • 2,482
0 votes
1 answer
467 views

Problem Installing the Mobile SDK for android

I am not able to install the Sales force mobile SDK from GIT hub, i tried to download the zip file and also run the install.vbs file, but it gives error as 'There was an error getting the status of ...
Sushma Rao's user avatar
6 votes
5 answers
3k views

Problems Installing Force.com IDE

I read Woody Leonhard's article in InfoWorld on the dangers of Java yesterday, so I uninstalled the two JRE's on my Windows 7 computer, and then reinstalled the latest version. This is what I have now:...
David Claiborne's user avatar
10 votes
3 answers
3k views

Can't install managed package because packaged permission set seems to have lost a read permission

I developed a Managed Extension Package. When I try to install it or create a patch org for it, this fails with no error but the note to call Salesforce. Support told me that it fails due to: ...
Robert Sösemann's user avatar
8 votes
1 answer
3k views

Managed package install script - sObject type not supported

I have a managed package with a PostInstall script, however I'm having trouble accessing custom objects within it. Apon installation, I get the following error notification email System....
James Davies's user avatar
  • 1,124