Questions tagged [force.com-ide]

The Force.com IDE is a powerful client application for creating, modifying and deploying Force.com applications.

55 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
7
votes
1answer
619 views

Eclipse IDE V36 Java Null Pointer Exception - Run Configurations

I recently upgraded my Mac Force.com Eclipse IDE to V36 because I liked the Windows version V36. (Separate client engagements in case you were wondering) When I click Run Configurations in the ...
4
votes
1answer
2k views

Deployment of SiteDotComSites: Required field is missing: label

I've pulled all the metadata from a sandbox, and now as a sanity check, I'm trying to push it all back (via Force.com IDE) to the same sandbox. It all seems to work apart from siteDotComSites ...
3
votes
0answers
2k views

Unable to authorize existing scratch org from Force.com IDE 2

I'm unable to authorize an existing scratch org (created with the SFDC DX CLI) in the Force.com IDE 2 I do the following: On command line: display org detail using sfdx force:org:display -u <...
3
votes
1answer
305 views

Spring 16 release: latest Force.com IDE throws invalid credentials error

I've encountered with an issue after Spring 16 release has been deployed. Basically I cannot do anything with my project in Eclipse (Kepler + latest available Force.com IDE), every time it just throws ...
3
votes
2answers
115 views

How to enable notifications in Force.com IDE that file was modified on server?

How to enable notifications in Force.com IDE that file was modified on server? Now several people in the project work with one class and we just simply overwriting each other code..
3
votes
2answers
270 views

Force.com IDE Install - No repo found

Our company uses MyEclipse Blue with Eclipse 3.7, so the latest IDE version I can install I believe is 28.x.x I had it installed before but I was having problems so I decided to uninstall and ...
2
votes
0answers
92 views

How to create a force.com project in a SSO sandbox

Recently, we enabled Single Sign On in one of our sandbox. When I try to refresh metadata using Eclipse, I am getting following error. I have tried by specifying different environment which matches ...
2
votes
0answers
870 views

Force.com IDE issue - unable to find valid certification path to requested target

Getting below error while installing force.com project. Eclipse : Marc JDK 1.8 JRE 1.8 for 64 bit computer Unable to fetch organization details for redacted unable to find valid ...
2
votes
0answers
181 views

Can't Run Tests in Force.com IDE

I just got a new work pc and I got all my software reinstalled. The version of eclipse that our company uses is compatible with only up to version 36 of the Force.com IDE, so I can't use 37 at this ...
2
votes
0answers
214 views

Force.com IDE debugger Issue

I am facing the following error from Eclipse force.com debugger when i tried to debug the apex code. Encountered an error executing remote command Your Salesforce org doesn't have the permission ...
2
votes
1answer
81 views

AppExchange application contents appears outside of Referenced Package folder in Eclipse

I have a number of applications installed in my org, and majority of them appear in the folder 'Referenced Packages' in eclipse, except for some. They appear outside of the folder 'Referenced Packages'...
2
votes
0answers
229 views

Falied to create new custom object using Force.com IDE

I have one force.com project with 2 new custom object to be created in the server. xmls for these objects like : <?xml version="1.0" encoding="UTF-8" standalone="yes"?> <CustomObject xmlns="...
2
votes
0answers
332 views

Invalid field name: Contact.Activities$What

I am using force.com IDE to migrate reports. For a report of custom type Contacts with Activities, I get error: "Invalid field name: Contact.Activities$What" The report type is already deployed ...
2
votes
0answers
1k views

Connection timed out: Connect

While developing against sandbox (CS21) I continue to get time outs from Force IDE (Eclipse) when refreshing or saving changes to salesforce. This happens in a number of situations including ...
2
votes
3answers
499 views

Save error : Null - VF Custom Component - Eclipse IDE

I'm using Eclipse Kepler and the Force.com IDE for Spring '15. I've created a custom component that I can't save in the IDE. This component defines a pageblocktable, which includes a column defined ...
1
vote
0answers
24 views

force.com ide has to reinstall on every startup of eclipse

I installed Neon.3 Release (4.6.3) and Force.com IDE, lightning support and debugger. However everytime I close eclipse I'm prompted to reinstall these three components as if I never installed them at ...
1
vote
0answers
135 views

Apex MyProfilePageController class bug

While trying to deploy apex changes to prod I receive an error for the MyProfilePageController class. I found https://developer.salesforce.com/forums/?id=906F000000099W9IAI. This is an issue from 2010,...
1
vote
1answer
150 views

Setting up visualstudio to work with an existing org and sandbox?

I've always worked on the web console. I recently moved to visual studio but I'm having trouble setting up the system. In short, I'm experiencing information overload and I'm wondering if anyone ...
1
vote
0answers
24 views

Eclipse Neon updates server with components I haven't saved

Running Eclipse Neon 4.6.0 and Force.com IDE 37, and whenever I have it set to build automatically and work online, when saving changes to a component I'm finding multiple components updated that I ...
1
vote
0answers
43 views

How to change the lead layout to default layout using ANT

I have a requirement to enable the default button for Lead Layout using ANT tool. This is my Package.xml file <?xml version="1.0" encoding="UTF-8"?> <Package xmlns="http://soap.sforce.com/...
1
vote
0answers
580 views

Can't connect to salesforce with force plugin for eclipse

I'm using eclipse 4.6.3 with Force.com IDE 38.0.0.201701101558. When I enter my credentials in project properties it says com.salesforce.ide.core.remote.ForceConnectionException: Unable to create ...
1
vote
0answers
444 views

Force.com IDE Required field is missing: encodingKey

I successfully deployed my files to the Salesforce server yesterday but today, I got a "Required field is missing: encodingKey." It says the Resource is .DS_Store and the path is leading to the email ...
1
vote
0answers
69 views

Why Contact object metadata is not returned when refresh server using Force.com Ide?

I am using Force.com Ide and refresh the object from server.Here my package.xml <?xml version="1.0" encoding="UTF-8"?> <Package xmlns="http://soap.sforce.com/2006/04/metadata"> <...
1
vote
0answers
648 views

Force.com IDE + EGit: Files tagged with “Dirty” are not actually dirty (aside from crlf differences)

Eclipse's Package Explorer is marking my file as Dirty. But when I compare the file with the index (ie, Right click > Compare With > Git Index), I see no differences other than my line endings, which ...
1
vote
2answers
63 views

Success when deploy with Out bound change set, fail with deploy with Force.com IDE or Mavensmate

So this is been going on for a while. Everything works when I use the build in outbound/inbound change set to deploy code form Sandbox to Production. And Fails every time trying to deploy the exact ...
1
vote
0answers
464 views

Issue with updating project in Force.com IDE

In Eclipse Luna, I am facing an issue with Force.com IDE. It is working fine while creating Force.com projects. But after creating projects when I try to refresh it from server or add components to ...
0
votes
0answers
23 views

Mavensmate: Workaround for Client Identifier Error

We all know that Mavensmate was put to rest not too long ago but I've seen a few forums discussing the possibility of bring it back to life with a client identifier workaround? Can someone explain ...
0
votes
1answer
67 views

infonot a valid enumeration for type class com.sforce.soap.metadata.deployproblemtype

While validating Package.xml from Force.com IDE to Salesforce org, I am getting error: infonot a valid enumeration for type class com.sforce.soap.metadata.deployproblemtype <?xml version="1.0" ...
0
votes
0answers
56 views

Unable to create new project in Eclipse

I have installed latest Force.com IDE in eclipse in my local system. I am unable to create a new project. I am able to enter username, password under force.com project, then when clicking on NEXT ...
0
votes
0answers
32 views

Not able to create a new Force.com IDE project on macOS Mojave

after I fill in all the required (username, password, security token and environment) and click "Next>" nothing happens :( No error even
0
votes
1answer
51 views

How to retrieve custom fields through force IDE?

I have retrieved all the custom and standard objects in my force IDE, but I am unable to retrieve Custom Fields. Because of that objects are not deploying in the target org, I have to create manually. ...
0
votes
1answer
47 views

Unable to create project in Eclipse using Lightning HostName

I am trying to connect to sandbox from Eclipse. My org settings wont allow me to connect to sandbox using test.salesforce.com. I have to put hostname to create a project. As we know we have different ...
0
votes
0answers
87 views

Run the `.app` created in Eclipse Force.com IDE

How could I run the .app created in the Eclipse Force.com IDE? By run I mean to perform a preview similar to the one I can perform in the developer console. Here is the best example I was able to ...
0
votes
1answer
47 views

Problem understanding Permission Set xml in Eclipse IDE

I have a Permission Set which has access to some Classes and Pages and one Custom Field on the Account object. When I am trying to see the file in Eclipse IDE, it shows as just the following, even ...
0
votes
1answer
19 views

Force.com IDE: I want “work offline” to be default

Every time I switch the source for my project (between sandboxes or between production and a sandbox) it defaults to "Work Online", and I need to remember to switch that or else it starts deploying ...
0
votes
0answers
31 views

Versioning project on github

I'm trying to store my project on github using Force.com IDE Tool (ant). I have created a new command to store my project on github defining it in the build.xml file: <macrodef name = "git"> ...
0
votes
0answers
168 views

Force.com IDE Eclipse Anonymous execution Debug

So I have just started using eclipse with the Force.com IDE. I am executing code in the anonymous window and it shows me that the execution was successful. However, I have a System.debug(); line in my ...
0
votes
1answer
44 views

Unable to go online in force.com ide

I just finished setting up eclipse oxygen and created a force.com project successfully, with the basic components like class, page, trigger etc. When I try to "work online" it shows the below error. ...
0
votes
0answers
226 views

Unable to delete class from production

For some reason I'm not able to delete specific class from production. Earlier I comment all the code and it was deployed ok from Dev--> QA, and then from Dev --> Prod. Now I want to delete this ...
0
votes
1answer
256 views

Apex Test Results in Eclipse not reporting correctly

I'm using (the apparent latest because there's no updates ATM) Eclipse Neon v4.6.3 Force.com IDE v38.0 When I run my Apex unit tests, I only get a green checkbox in a single item in the test results ...
0
votes
0answers
126 views

Force.com IDE V38.0 test running issue

I just updated the Force.com IDE to the latest version, however, I am having issue running unit tests. When I open the "Run as configuration" dialog, I receive an error: And when I filled in the ...
0
votes
1answer
114 views

Eclipse Force IDE: Found read only local file content not in sync with remote instance. Use Synchronize to resolve conflict.

I am trying to update the leads object with new fields I created using force ide. However, whenever I try I get the following error: Eclipse Force IDE: Found read only local file content not in sync ...
0
votes
0answers
128 views

Can't create Lightning Components via Eclipse (beta)

I have tried to install Force.com IDE in Eclipse and also download the feature to be able to work with Lightning Components in Eclipse. However I was not able to make it work. I have also asked for ...
0
votes
0answers
50 views

No mm_workpace bit in User Settings when trying to set up MavensMate in Sublime Text 3

I'm trying to get MavensMate up and running, but when I try and load the User settings under the MavensMate header there a couple of things different from the Apex Academy demo I'm trying to follow. ...
0
votes
1answer
99 views

How do I create a Permission set through script/eclipse or mavensmate ?

I want to create 66 permission sets in the sandbox through eclipse or another IDE can you please suggest me how i do this through script. please help me > ?
0
votes
1answer
308 views

Force.com IDE not displaying custom fields, recordtype section under custom/standard object

I'm using eclipse-dsl-kepler-SR2-win32 and Force.com IDE http://media.developerforce.com/force-ide/eclipse42. In the Custom/ Standard object section, individual custom fields , recordtype etc are not ...
0
votes
0answers
510 views

Sublime Text 3 : HaoIDE all options disabled

I have been using Sublime Text 3 : HaoIDE for Force.com Development for last 4 months. After I updated Sublime Text 3 to build 3114, all options under HaoIDE menu are disabled, restricting me from ...
0
votes
0answers
503 views

Force.com IDE in Eclipse Access Denied

I try to install Force.com plug in based on instruction , but it fail at step 3..At first I thought it is maybe because of network connection in my company.So I try to paste the url 'http://media....
0
votes
0answers
254 views

Why doesn't Force.com IDE / metadata API download all objects and WF rules?

I configured my Force.com project in Eclipse to download ALL standard and custom objects, but it skipped some, e.g. it didn't download CaseTeam, CaseCommnet, EmailMessage, etc. - at first I thought ...
0
votes
0answers
211 views

How to fix Eclipse project upgrade issues?

I updated the force.com plugin to 35.0 .I am getting below error on trying to upgrade my project to summer 15. Unsupported_API_Version - Invalid Api version specified on URL. Any idea how to resolve ...