Questions tagged [deployment]

Deployments in Salesforce incorporate any action that needs to be taken to get a system from one organization to another, be it a sandbox to production, sandbox to sandbox, or even developer org to developer org.

339 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
1
vote
0answers
265 views

Migrating components not supported by eclipse

How do we migrate metadata from one org to another when they are supported by metadata api but not by eclipse. The examples are sharing rules and matching rules. I have managed to migrate this from ...
1
vote
1answer
184 views

Unable to Deploy file-based Custom Field / Profile Settings to Salesforce SOAP API

We've visited the following link, and followed the examples/instructions to no avail. https://developer.salesforce.com/forums/?id=906F0000000AVifIAG We originally utilized the CRUD-based SOAP API to ...
1
vote
0answers
24 views

Migration tool took more than the expected time to finish the deployment

Validations and deployments via migration tool to a sandbox took more than the expected time to finish the deployment. Total deployment/validation time supposed to be roughly 30 minutes and suddenly ...
1
vote
1answer
54 views

Can you automate a release that changes the type of a field that is referenced by a class?

The problem In production we have a field that is referenced by a class. We want to change that field from a 'text' field to a 'formula' field. In order to change the field from one type to another ...
1
vote
0answers
523 views

deploying Field level security

what is different from force.com 28 to 31? i was able to move the field level security using force.com 28 without adding profiles to the package. but with the newer versions of Force.com >= 31 it is ...
1
vote
1answer
118 views

Using Quickdeply from metadata API

Do I need to pass any special parameters when I use Quickdeploy using metadata api ? Or should I just use the validate option and it sends the info to the org for Quickdeploy? How does ANT know when ...
1
vote
0answers
108 views

We could not deploy with a new process running

I created a new process , When we tried to deploy change sets today, I received the unhandled process fault email message. The message includes apex failure and Apex Failures:Pre deploy test failed, ...
1
vote
0answers
95 views

Error SOQL 101 while deploying inactive trigger

I have requirement to inactive the trigger on production. For that I am using sales force chengeset functionality. But I am unable to understand it is giving 101 error if deploying inactive trigger ...
1
vote
1answer
48 views

Unlock self login id

I have system admin profile. I am trying to connect to Sandbox(Developer Pro) from IDE Eclipse. My id is getting locked out and not able to connect and throwing login error. However I can connect to ...
1
vote
0answers
57 views

APEX — Error on custom lead conversion code!

I have an APEX code that will convert Leads (it's triggered at the conclusion of a flow): trigger CustomLeadConversion on Lead (after insert,after update) { LeadStatus convertStatus = [ ...
1
vote
1answer
64 views

How to generate Helper class runtime

Is there a possibility or did anyone tried to generate an Apex helper class based off certain conditions runtime. I am thinking this just for LEARNING prospective. This will also reduce the number of ...
1
vote
2answers
63 views

Success when deploy with Out bound change set, fail with deploy with Force.com IDE or Mavensmate

So this is been going on for a while. Everything works when I use the build in outbound/inbound change set to deploy code form Sandbox to Production. And Fails every time trying to deploy the exact ...
1
vote
1answer
44 views

Give ANT deployment a label

Is there anyway to specify a name on an ANT deployment, instead of just an 18 character guid? It would be especially helpful with for the new quick-deploy feature.
1
vote
0answers
661 views

Deployment Error - Flow Must Have a Start Item

I am trying to deploy a flow that simply invokes Apex. It works as expected during functional testing. However, when I attempt to deploy it with Eclipse, I get the below error. Deploy Results: File ...
1
vote
0answers
392 views

Metadata API Case-Sensitive?

is the Metadata API Case-Sensitive? Scenario: Take for instance the following scenario: a multi-org strategy where all development is being done on a Sandbox related to Org ABC. From that Sandbox ...
1
vote
0answers
238 views

mavens mate save to active org

Setting "mm_compile_with_tooling_api" set to false allows me to change and save apex classes on even production org. I found it useful when i have quick small fix to publish but i wanted to ask is it ...
1
vote
0answers
169 views

deleting apex class without dependency check

I remember I was not able to delete apex class when you are using class on another controller or components. However I can delete apex class even I am using on another page and the page is not deleted ...
1
vote
1answer
48 views

Deploying profiles from two unconnected orgs

I wanted to know, if I could deploy some profiles from two orgs that are not connected, through Java - Ant procedure. Actually, one org is a sandbox and the other is a production/developer. The orgs, ...
1
vote
1answer
68 views

Deploy Controller Changes - Attempt to de-reference a null object

My developer is on vacation, and I'm trying to deploy changes to a test class (TicketEditedTest) and I keep getting deploy failures: Invoice_Thank_YouController.testInvoice_Thank_YouController ...
1
vote
0answers
800 views

SObject deployment: Cannot specify a startsWith attribute for this language

I'm trying to deploy an sobject to a new empty environment. I get the following error: Cannot specify a startsWith attribute for this language Both orgs are in English. Any thoughts? Edit: The ...
1
vote
0answers
120 views

More “approved” components than were added

So I was using salesforce Change Sets to send a project from sandbox to production. I have control over both so I know what is outgoing and what is incoming. I was sending some fields and a layout (30 ...
1
vote
1answer
155 views

New Force.com IDE not auto-deploying? (NOT A DUPLICATE QUESTION)

I am having the same issue as here New Force.com IDE (Eclipse) - not auto-deploying?, except the solution chosen isn't working. I have Build Automatically checked and I've also already selected "...
1
vote
1answer
384 views

PersonMailingAddress Field Not found error during deployment ONLY

So I am trying to deploy a changeset and in one of the tests I am referencing the PersonMailingAddress with the following query: [Select Id, PersonMailingAddress From Account Where Name Like '%Test%']...
1
vote
1answer
2k views

How to deploy a Login flow in Salesforce using ANT Migration tool

I have a login flow which uses the visual flow and displays a welcome message to the user when they login.I don't see this in metadata ,How can I deploy the login flow using ANT Migration tool.
1
vote
1answer
631 views

Causes of organization lock

I recently tried to deploy some changes between sandboxes using the Force.com migration tool and got the following error: Failed to process the request successfully. Cause(ALREADY_IN_PROCESS): null:...
0
votes
0answers
24 views

Invalid property [enableActionsInNative] in component [force:highlightsPanel] when deploying

Came across these two errors when deploying my first change set. I've read another thread where it says to delete your highlights panel, but I'm not sure how to do that. Do I delete the highlights ...
0
votes
1answer
33 views

Retrieve record type label's translated value

I have translated record type label name in translation workbench but not able to retrieve it in package xml. record type is not coming in below xml: * CustomObjectTranslation How can I ...
0
votes
0answers
20 views

Help deploying lightning component from git clone

I'm new to git and trying to deploy some lightning components to my developer sandbox for testing. The git page is: https://github.com/CharlesHGong/lightningRelatedListWithFilter In vscode, I believe ...
0
votes
0answers
13 views

Admin.UserCanEditFieldPermissions error while deploying using Bamboo

Error: "profileName", line 0: Error Admin.userCanEditFieldPermissions Having trouble finding information about the above error when deploying Profiles using Bamboo. The deployment in ...
0
votes
0answers
33 views

Profile Metadata Missing

I am retrieving Profiles and custom fields with Package.xml, But there are fields permission missing. *<?xml version="1.0" encoding="UTF-8" standalone="yes"?> <...
0
votes
0answers
12 views

Heroku app is using old js file instead of github updated file

I pushed the changed js and html file to github. Heroku is auto-deploying with github's new file. But when I browse the app, the html files are updated but js files are not update old files. The ...
0
votes
0answers
41 views

Deploying lightning web component from VScode to sandbox takes more time

I am trying to deploy lightning web component from VScode to the sandbox using the command SFDX:Deploy Source to Org. It was working fine previously but for the past 2 days, deploying is taking more ...
0
votes
0answers
10 views

I deploy an application to Heroku and it get publish to an http url instead of an https

I have an application that when I deploy it to heroku it gets published to an HTTP instead of an HTTPS url. In the https url appears an old version of the application, and I don't know how to remove ...
0
votes
0answers
19 views

Deactivating duplicate rules then redeploying as active does not activate duplicate rules

I ran into this situation: I have duplicate rules in a sandbox. I deactivated them manually. In my local code repository, I have the duplicate rules version controlled in package.xml: <types>...
0
votes
1answer
31 views

Unable to deploy contact object and custom setting

I am trying to deploy contact object field,email alert and custom setting but during deployment getting below errors. objects/Contact.object -- Error: Error parsing file: Element fields is duplicated ...
0
votes
0answers
34 views

Cannot deploy flow, Getting error 'Screen component 'ComponentName' is missing a type mapping 'T'

I have created a flow screen component that work for multiple object. In the flow, I have created a collection variable. I have created an LWC component that uses the collection variable. When I try ...
0
votes
1answer
55 views

How delete class from Production that doesn't have code coverage

I have two classes on production org that is like a default class (supersort and TrialCustomerPortalHomePageController), but does not have code coverage at all. So because of that I'm not able to even ...
0
votes
0answers
17 views

Regarding deploying code from one production org to another org

I tried creating a project with manifest.using the package.xml i've pulled all the data from the org1.then i authorized org2 and deployed the source into that org.my code is successfully deployed but ...
0
votes
1answer
70 views

How to deploy Quick Action Page Layout using change set?

How to deploy a create record Quick Actions layout using change set? I am deploying the quick Action using 'Action' Tag in changeset but i do not get the page layout of quick action. Only predefined ...
0
votes
0answers
29 views

VS code Package.xml not retrieving new components

I am trying to retrieve new components such as ApexClass through "sfdx retrieve source in manifest from org" on the package.xml (sample below), and it doesn't retrieve any new components ...
0
votes
0answers
50 views

Ant validation/deployment errors using sessionId

I have a weird problem with Ant setup on CI. I have a script that fetches access token using JWT. The token is retrieved successfully, and when I want to use it with Ant deployment (switching in ant ...
0
votes
1answer
44 views

Can change set with warning still be deployed?

When during deploying change set to prod you get a warning like long-running apex test Can you still successfully deploy that change set or does the warning blocks it?
0
votes
0answers
46 views

SFDX deploy error : Infinite Loop Detected

I am new to SFDX. I have been assigned to deploy a local salesforce directory to an org on salesforce. But I am getting the following error and there is no more details about the error. I tried ...
0
votes
0answers
40 views

Deploy with BitBucket pipelines and ant migration tool - commit hash of last successful build

I am using ant migration tool in bitbucket pipelines to deploy metadata into Salesforce instance. This pipeline runs for every commit pushed to master branch. The build process takes a considerable ...
0
votes
0answers
32 views

Error INVALID_CROSS_REFERENCE_KEY in test class when deploying to production

I'm getting this error System.DmlException: Insert failed. First exception on row 0; first error: INVALID_CROSS_REFERENCE_KEY, invalid cross reference id: [] Stack Trace ... This production org is ...
0
votes
0answers
86 views

Error deploying LWC in change-set. Programmer error: Cannot compare savepoints from two different transactions

I have two Lightning Web Components that consistently fail when I try to deploy them in a change-set. The two LWC are the only components being added in the CS and the error is consistent. Everything ...
0
votes
0answers
21 views

Deleted a connected app from a managed package. Now all prior versions of the package won't install

We deleted a connected app that was part of our managed package yesterday, since we no longer use it. This has caused installing any previous versions of our package and any patch we build to fail ...
0
votes
0answers
24 views

Cannot deploy Feed Tracking for Event Custom Fields

We have created a couple of Activity Custom fields and we have enabled Feed Tracking for them in the Event Feed Tracking section. As far as I can tell, in order to deploy Feed Tracking for a field, ...
0
votes
0answers
61 views

Lightning Email Template Deploy: How do I get the Lightning Email Template Folder Id?

I have Lightning Email Templates that I need to deploy to 13 orgs, and rather than recreate them manually in each org I've extracted them with Data Loader, and now I need the Public FolderIds from ...
0
votes
1answer
39 views

Deploy failed because of Metadata.Operation.retrieve

everyone! I have following part of code: When I validate code during deployment I get errors. Errors are - 'System.ListException: List index out of bounds: 0' on line 77. When I try to use this code ...

1 2 3
4
5
7