Questions tagged [bug]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
5
votes
1answer
140 views

SOQL bug for null required-lookup fields?

It appears that querying null values for required lookup fields always returns 0 results, even if some records have no value in the required field (e.g. records created before the field was made ...
19
votes
3answers
10k views

Lightning navigation does not refresh the state of components, how to fix a bug

I am using lightning:navigation component in our project, and it doesnt refresh the state of component, when the url changes. To be clear, lightning framework just keeps the state of component/page ...
0
votes
0answers
13 views

Bug? Flow InterviewLabel does not match Version Label in Salesforce Production

I recently created a flow. We had several iterations on this and the flow version number in Sandbox was 59. After deploying, the latest version of the flow was version 39 according to the user ...
5
votes
2answers
665 views

How can we fix the Lightning Component ui:inputDate DatePicker position?

I'm in need of implementing a lightning component that includes ui:inputDate component with displayDatePicker=true. The component is mainly only for sidebar purposes in Lightning Page. But when I ...
5
votes
1answer
981 views

Stop SF Lightning from trying to open up Set Up Content in a new tab

When I am in Set Up and attempt to open something, like User Profiles for example, I always get this modal that asks We'd like to open the Salesforce page ... in a new tab and then when you allow it, ...
2
votes
1answer
1k views

Error: Can't change quote owner. Enable quotes without parent opportunities

I am desperately looking for some answers to this considering Salesforce Support is non-responsive at the moment and this is time-sensitive. We are currently launching/transferring a majority of our ...
0
votes
1answer
33 views

Internal Server Error when building emails

Since Monday, I am having an issue that is affecting the email creation in Email Studio. . It happens in the header image of the template and it breaks the layout of the email. Even when trying ...
0
votes
2answers
55 views

Preheader text box not displayed in the Content tab of the email

I am having a really weird issue in Email Studio. When I open an email, on the first screen I can see the subject and the preheader like in the image below. But, when I click in Edit Content, I don'...
0
votes
1answer
51 views

Images are not displayed after sending the email

I built an email in Marketing Cloud where some pictures have been attached directly from Content Builder (drag-and-drop). When I send the email, the image is not displayed in most of the different ...
5
votes
4answers
788 views

Javascript Remoting Update causing INVALID_TYPE_ON_FIELD_IN_RECORD for Integers

I'm passing a Javascript object through JS Remoting to update an Account record. However, if I update the NumberOfEmployees field, I'm getting the following INVALID_TYPE_ON_FIELD_IN_RECORD Employees: ...
2
votes
2answers
318 views

JSON deserialize issue inside a try/catch block in an Apex in a web service

So I have the following code: @HttpPost global static void execute(){ String json = RestContext.request.requestBody.toString(); JSON.deserialize(json, List<DTO>.class); } but when ...
0
votes
1answer
50 views

Email content displayed twice after sending

From time to time, some emails are displaying content like the header or the footer twice after sending it. In the preview, everything looks good. Is there any reason behind? We are using an HTML ...
0
votes
0answers
32 views

getUrl in preview org as guest user

I started testing on a preview scratchorg and found that the following line would result in the " is down for maintenance" error on the site. ApexPages.currentPage().getUrl(); getParameters instead ...
3
votes
0answers
93 views

<apex:outputField> on URL-field renders Popup - blocked in Chrome

In a Visualforce page (embedded into Page Layout sections) I reference a custom object with an URL field using: <apex:outputField value="{!record.SupportLink__c}"/> When clicking the link ...
5
votes
1answer
633 views

Spring 20 - Validation rules that use “$UserRole.DeveloperName” are triggering when they should not

After the Spring 20 release my validation rules that make use of the field "$UserRole.DeveloperName" are triggering when they should not. I'm currently trying to create a case from a community (with ...
5
votes
2answers
547 views

Decimals pretending to be Integers when used in Maps

I came across some very strange behaviour when working with a Map with Decimal keys today. It seems like the Decimal type can't handle Integer assignments properly, but allows them nonetheless. I've ...
4
votes
0answers
59 views

Can we work around Owner related fields not being retrievable via SOQL in apex tests?

Background: Recently I wrote a very simple Batch to run on the 1st of every month. Its purpose is to query for any Project__c records that aren't Complete, and create a related "Carry-Over" record in ...
1
vote
1answer
408 views

Currency field displayed with different currency depending on language parameter in Visualforce page!

I recently got a problem when trying to use language parameter in my Visualforce pages. In a single currency org (French EUR, multi-currency feature not activated), if I set the language parameter to '...
1
vote
0answers
52 views

Visualforce Lookup field search icon not working on Salesforce Mobile App (Android)

I've a Visualforce Page overriding New & Edit standard buttons. On Salesforce Mobile App (Android) only, the lookup field search icon does not work. It throws users to login page and when they ...
1
vote
1answer
40 views

Filtered Data Extension bug

I have an issue when applying filters in a Data Extension for a few days ago. Basically it doesn't work. For example, if I did a filter from a Data Extension adding the criteria 'Email is not null' ...
0
votes
0answers
90 views

Process Builder recursion issue: repeats actions 6 times

I'll skip the overall context and just describe the current issue at hand. I have a Process Builder on Object X, with Recursion turned ON. We need recursion turned on for all our automation to work ...
1
vote
2answers
85 views

SOQL with 'like' is not returning data records correctly

I've a query executed using database.query() method. The query looks like this: Select Id, Name from CustomObj__c WHERE Name like '%admin, ray%' ORDER BY Name I can execute this query directly in '...
0
votes
0answers
55 views

Problem with a standard Lightning Component tag in my sandbox probably after the Winter'20 Update. Where should I request to fix this issue?

Using the following code I am getting two pop-ups if I hover a stage. I also tried these exact codes on other editions(including developer edition). Its working perfectly alright. I even found the bug ...
4
votes
1answer
130 views

How to push source to Scratch org if project code exceeds 50mb limit?

I have a managed application which I'm now trying to move to DX platform of development, but I'm getting an error of exceeding maximum storage: Maximum size of request reached. Maximum size of ...
1
vote
2answers
2k views

lightning:datatable actions menu is hidden

The actions menu that is supposed to show when you click on the downward arrow on the right-end of a row is not showing. My component is dead simple: there is a lightning:datatable inside it ...
4
votes
2answers
213 views

Scratch Org: DUPLICATE_VALUE, duplicate value found: <unknown> duplicates value on record with id: <unknown>: []

I and my whole team encounter this error while inserting some data into a new Scratch Org. DUPLICATE_VALUE, duplicate value found: <unknown> duplicates value on record with id: <unknown>: ...
3
votes
1answer
2k views

Task Email Notifications via APEX not working, could be a Bug in platform or as designed after Winter 15?

Database.DMLOptions dm = new Database.DMLOptions(); dm.EmailHeader.triggerUserEmail = true; Task t = new Task(Subject='Test Task', ActivityDate=date.today(), OwnerId='00590000000wND2'); database....
0
votes
1answer
868 views

Can't pre-populate datetime value in <lightning-input-field>, Summer '19 change/bug?

This issue has just appeared since Summer '19 rollout. It was working correctly before. I have an LWC with a <lightning-record-edit-form> for creating a new appointment record (so no record-id ...
2
votes
0answers
44 views

Differently aligned Save and Cancel button in debug edit page Summer 16

In a Summer 16 org i'm seeing some UI changes at least in Edit trace flag screen. When i edit user trace flags for my user I see the Cancel button is left aligned and Save is right aligned (They ...
11
votes
1answer
363 views

toLabel in @AuraEnabled Apex Lightning controller

EDIT: This problem seems to have been fixed on Salesforce's end. See Shamina's answer below. The SOQL toLabel function doesn't work in my @AuraEnabled method when called from a Lightning component. ...
0
votes
1answer
168 views

Salesforce Lightnining unable to see full values in UI Picklist

In Salesforce Lightning Experience, whenever I have a 'Classic view' picklist, when I click on the picklist to choose a value, I am unable to view the select options: If i minimize my browser window ...
0
votes
2answers
234 views

lightning-input-address embedded in VF page. Address lookup not working

I have a use case to embed a lightning web component in a VF Page (in Classic) which includes a lightning-input-address component. The component includes the standard address lookup input (which ...
3
votes
4answers
4k views

apex:outputField not applying styleClass — bug?

In a Dev Org, I have a Visualforce Page where I have <apex:outputField value="{!item.Cost__c}" styleClass="item-cost"/> but the Visualforce Page doesn't apply the class item-cost to the span-...
4
votes
3answers
5k views

How do we pre-populate force:inputField in Lightning Component?

I'm trying to preset a Lookup field when my Lightning Component form loads, but the field is always showing as nothing selected, even though the value exists in the field itself. The code looks like ...
6
votes
1answer
313 views

lightning-record-form failing when User doesn't have access to a field

There seems to be an issue with lightning-record-form in Summer'19. According to documentation it's supposed to take care of field-level security and it used to (not showing a field to which User ...
1
vote
2answers
327 views

Before Trigger is not picking up BillingCountry on the Account Object

My class is suppose to pick up The Billing Country and Billing Postal Code and populate the state based on those two fields, however when debugging the before trigger It doesn't pick up the Billing ...
3
votes
0answers
73 views

Why I can't login to Lightning Experience? (only Classic is working)

As of today I can no longer login to newly created DE Orgs spun with the Environment Hub. Login works sometimes directly after creation for some minutes or does not work at all. It just shows an ...
3
votes
2answers
2k views

LWC css is only partially applied [duplicate]

Within this component our css is only applied to the div within the card but not to any div in the <header> (title). Is there a feasible reason or is it just a bug? (In our real problem we are ...
4
votes
1answer
472 views

SAML Assertion Validator crashing on encrypted assertion

I'm adding support for encrypted assertions to my SAML 2 IDP, and I'm trying to validate them against a number of SPs we work with. Everything looks good at https://www.samltool.com/online_tools.php (...
4
votes
1answer
1k views

Are Lookup Filters supported in Custom Lightning Components?

So, there are two ways to get Salesorce Standard Lookup filed in Lightning components: force:inputField and lightning:inputField. However, no matter what I do, I can not get lookup filters to work. ...
2
votes
1answer
101 views

Bug? String.split chopping off empty trailing value

I have found this strange behavior by trying to write a unit test against a CSV Generator. It seems that if I try to split a string by comma, and there is an empty trailing cell, these values are ...
1
vote
1answer
324 views

Apex Batch Jobs stop executing unexpectedly

Hi so we have a couple of Apex batch jobs that run continuously in our org. One runs every five minutes and one runs every fifteen minutes. In the batch's finish methods, the two reschedule ...
1
vote
0answers
456 views

Unable to pass Custom Parameters to a Visualforce Page via URL button in Lightning Experience

I've a Custom Object whose NEW and EDIT Standard Buttons/Links have been overridden with a Visualforce Page. This Custom Object also has couple of Record Types on it. I've added a Custom URL Button ...
2
votes
1answer
103 views

Adding days to the Date portion of DateTime throws off the Time portion

So I'm having an issue in Apex with the Date's addDays function. It seems that adding more than a certain amount of days throws off the time by one hour. It all seems so arbitrary so I'm wondering ...
0
votes
1answer
324 views

Repeat checkbox not working on Global Actions quick action layout for event

When on the calendar tab or event object directly checking the repeat checkbox expands another menu allowing the user to choose the repeat interval. However, when creating an event from an associated ...
0
votes
1answer
129 views

Did salesforce changed sender profile implementation? Bugs for me

Today a message of salesforce popped up: Unfortunately it popped up after we had a journey activity that had send emails. We changed nothing at our sender profiles (that work with ampscript) or the ...
10
votes
4answers
452 views

Is MIXED_DML_OPERATION in unit tests broken?

We have a nightly integration that runs all tests and reports any errors against production, currently on Winter '19. Everything was fine until January 14th, 2019, when 13 previously passing tests ...
4
votes
0answers
84 views

`sfdx force:data:tree:import` FAILS when field API name has numbers in it

I'm posting this issue again as it is not resolved yet. I don't understand why it's not part of the known issues of Salesforce DX. This has been reported here 5 months ago, with a temporary fix. The ...
1
vote
1answer
334 views

Custom Button URLFOR not assigning proper record ID when clicked

I am trying to implement a custom button on a record detail page that does the following: redirect user to custom lightning component with querystring: ?projectId=... I am using the following ...
2
votes
1answer
74 views

Dynamic sObject Lookup field throws “SObject row does not allow errors” if lookup is entered record name that do not exist in org

Feels like I'm not having a good day at all with platform :-) ... another day and another issue with platform dynamic sObjects :( So I'm trying to create an sObject record dynamically from a VF page. ...