Questions tagged [api-version]

The tag has no usage guidance.

Filter by
Sorted by
Tagged with
0
votes
1answer
38 views

Downgrade Aura Component API version

I am trying to downgrade aura component api version to 39.0 from visual studio code, and push it back to sandbox. I can see that it's been changed in visual studio, but hasn't changed in Salesforce ...
0
votes
2answers
151 views

Test/API Difference with Regards to EmailMessage and Messaging.SendEmail()

Any resources on what might've changed in API 37 that wasn't present in 36 that could be causing the issue I'm seeing? If I update every other apex class in my org to 46 and leave the test class at ...
1
vote
2answers
363 views

Version error when uploading Change Set

I’m trying to deploy custom objects, custom fields, page layouts, compact layouts, Lightning pages and Global value set (global picklist) , when uploading changeset it is giving me API version error ...
4
votes
1answer
69 views

Is there a way in Apex to dynamically determine the ApiVersion the current code is executed with?

Assume we have an Apex class myClass.cls and we use it on several different Orgs. While the source-code is the same, on some Orgs we use different ApiVersion, e.g. some Orgs use v45.0, others use v42....
3
votes
4answers
728 views

Should I update trigger API version?

I am an admin and have looking through some of the old triggers that are currently in our org. There are a few of them that are still active and do some important job but are set to API version 20. ...
0
votes
0answers
98 views

Sublime Text with Mavensmate reverts changes made to package versions in Org

I have Sublime Text with Mavensmate plug-in. I have Mavensmate application which is connected to the Org. I made a change to the version of a package in an apex class. After that, I refreshed all ...
11
votes
2answers
363 views

Access to SObject Schema in Apex is very slow after API v44

We needs to use Schema and DescribeSObjectResult classes to get all SObject in the user's organization. But we noticed performance problem after upgraded to API v44. The following code could reproduce ...
0
votes
1answer
239 views

Deploy change set from sandbox to production unavailable

I have a process builder which I want to build to production, when I create a change set it says that this change set requires the "45.0" or later platform version, if it was a visualforce page I ...
1
vote
0answers
116 views

Mismatching versions-error when trying to install unlocked package

I created a new version of my unlocked package and tried to install it into a scratch org. Unfortunately I get the error Mismatching versions.. From what I know this error comes up, when one tries to ...
2
votes
0answers
31 views

Is there a way to specify an API version of a call to @RestResource?

I would like to specify an API version when I call a @RestResource via an API. Is that possible? Why For some reason, our Spring '19 sandbox is having a weird issue, and I'd like to fix this before ...
2
votes
1answer
215 views

Why do Apex classes have an API version

I am unsure why each class has an API version. I know during each release they have added functionality therefore previous versions would not support this but I feel there must be more of a reason. ...
0
votes
1answer
93 views

Apex class APi version update

could anyone suggest whether we can update API version of apex class through Apex/trigger. If i try to update ,i am getting DML operation not allowed on aepx classes.
3
votes
2answers
952 views

Is there a way to upgrade api versions of all apex classes without manually updating each of them?

I have an org with hundreds of apex classes, all of which have api versions ranging between 30-37. Is there an easy way to bring them all to the latest api version at once without resorting to manual ...
6
votes
2answers
167 views

Using newly released feature on an apex class having older API version

As you all probably know switch has been introduced in Summer'18 (API v43,0) release. I have started using it in my apex class which is having API version 36,0 and somehow it works in my sandbox. I ...
0
votes
1answer
43 views

Upgrading Managed Package will also upgrade the API Version of Apex Class if it is changed

I want to upgrade API version of one class to use new feature provided in new API version. But, I want to know what will happen when existing customer upgrade their Managed Package with new package (...
4
votes
2answers
263 views

What are the risks or drawbacks of creating Parameterized Interfaces using of the Apex API version 25?

Unfortunately, as of API version 26, SFDC removed parameterized interfaces. However, it is relatively easy to create new interfaces and set the version as 25. So, to take the example from ...
6
votes
1answer
58 views

Is the API Version available for Standard Fields/Objects with which the fields/objects has been introduced?

I have written a SOQL-tool which allows me stuff like SELECT * FROM ... It is based on APEX Schema functions and works very good. It expands and compiles a full list of fields in a string, which I ...
2
votes
1answer
177 views

Advice on recompilation of production classes

I have an APEX Class that needs some updates, that is on version 18. When I make the updates, the version is also updated to the most recent (v41). When I try to push to production I get errors saying ...
5
votes
1answer
1k views

Force.com IDE still in v38.0?

I am trying to update eclipse force.com IDE so that I can create lightning components with v41.0(with Winter 18 release feature). I do not see an update available and while creating the component/apex ...
2
votes
1answer
198 views

EventAttendee object deprecated after API 25.0

We have working code that is based on 25.0 API and used EventAttendee object in its SOQL. We are now trying to Migrate the code to latest 41.0 API but the EventAttendee object does not exists in the ...
0
votes
2answers
516 views

How do I upgrade salesforce API version?

How do I upgrade salesforce API version? If I click on Generate Enterprise WSDL the XML shows API version as 40.0, how to upgrade version to 41.0, I want to use the REST API calls
0
votes
1answer
68 views

Summer 17 Critical update - CSRF Protection - How would it affect VF pages below version 27.0

The 'Require CSRF protection' option on VF Pages are available only for pages with API version 27.0 or later. I was wondering if activating the critical update (Allow CSRF Protection on GET Requests ...
4
votes
3answers
4k views

Which API versions are still supported?

I see some posts that Salesforce supports all the back versions of its APIs. But I also see pages on Salesforce.com that only give an End of Life statement that API versions will be supported for 3 ...
3
votes
1answer
435 views

Is there a Patch release schedule? Can I request my org be upgraded to the latest Patch?

I recently discovered a bug that makes it impossible to deploy subscriber triggers on Platform Events. In my sandbox environment, the bug appears to be fixed. Yay! Unfortunately, that patch has not ...
1
vote
0answers
138 views

Upgrading to latest Salesforce Apex API version number

Our organisation has over 100 Apex classes, triggers and VF pages written over a period of 8 years. The versions of Apex API that we have used vary from 10 to the latest 40. Now we are trying to bring ...
1
vote
1answer
273 views

Unable To enable inline editing for Visualforce page Error: Inline Editing is supported for API Version 21 and above

I am trying to enable inline editing for a visual force page I created. However, whenever I try to save it I get the following error, "Error: Inline Editing is supported for API Version 21 and above." ...
0
votes
1answer
121 views

API describeSObjects() version 37 does not work with older versions

We have downloaded the Partner.wsdl version 37.0 from Salesforce, which we use with our application to connect to Salesforce(using AXIS) to read/write records and to build the metadata locally read ...
2
votes
1answer
114 views

How to manage API version differences in packages and subscribers?

I think we can all agree that in an ideal world whenever we upgrade the SF API in managed package code we desire stability in subscriber orgs. Unfortunately this appears far reaching in the world of ...
2
votes
0answers
724 views

Possible bug with Process Builder, Apex Unit Tests and API Version

I ran into this issue last week during a deployment and submitted as a potential bug. Not surprising, Salesforce Support pushed back heavily saying that this is a feature of the application, not a bug....
1
vote
1answer
89 views

Salesforce Transaction API version

In ORG we have multiple triggers for Opportunity with different API versions. Some of triggers are installed from managed package and have api versions 25-28. Local ORG opportunity trigger has api ...
2
votes
2answers
647 views

'Invalid field BillingAddress for SObject Quote' error when deploying to production

I have some classes that query and use the Quote.BillingAddress aggregate field. This works fine in sandbox (api version 34.0) and running tests against it compile and pass testing. However, when ...
1
vote
0answers
153 views

Render PDF in Landscape on API Version 33 or above? (Works on 26)

My visualforce page is rendered as a pdf with renderAs=pdf @page{size: landscape;} Unfortunately, this setting works only with API Version 26.0 and not 33.0. Is there a known alternative/workaround ...
8
votes
1answer
387 views

SOQL Error Only When Accessing Lead.Address Standard Compound Address Field From WorkFlow Triggered Task Insert

I've added a section of code to our task trigger that retrieves two sets of address fields from the lead or contact the task is being made on - see below-. private static void ...
4
votes
0answers
151 views

Calling APEX out of JavaScript the APEX-API Version is ignored

I run in an issue with calling APEX out of JavaScript, when i call my APEX class, the class is executed with API-version 34.0, but in the metadata of this class is the API-version set to 27.0. I need ...
11
votes
3answers
4k views

What is the best practice re: API Version of your Apex Classes?

I'm in the process of pushing some updates to some code I originally wrote 12-18 months ago, and the API Version is between 27.0 and 29.0 I know this is to protect the integrity of the test classes ...