0

I checked the profile settings. User has access to all fields and read access to object.
The page block has mode attribute set to edit but the page doesn't render input fields unless I add Create permission.
It affects all input fields referencing other objects that the one that has only read permissions.

1
  • is your object accessible to user?
    – Ratan Paul
    Nov 19, 2015 at 16:00

1 Answer 1

0

To open a record as "Edit", you not only have to have "Edit" in some field(s) but you also have to have "Create" or "Edit" permission to the object itself.

Obviously, "Create" will let you do an Insert and "Edit" will also update an existing record.

According to your OP, you only gave "Read" permissions to the object.

3
  • Is it documented anywhere? This is giving users a lot of permissions they shouldn't have. I wanted to create a page to disable the standard new button on related lists that appears when you grant create permissions. Looks like I can't escape it.
    – user682217
    Nov 19, 2015 at 17:03
  • You can do this. Controllers can run in "God Mode". Disassociate the object in the controller from the one created by the controller and it should work. Nov 19, 2015 at 17:35
  • that's lot of extra work :/. Wrapper class , checking FLS to render fields and I have a few lookup I would have to replace with picklists I guess
    – user682217
    Nov 19, 2015 at 22:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.