0

We have recently found that when we are trying to use the email preview feature within SFMC that rather getting a vaguely useful error message (e.g. syntax errors and lines numbers), we are now simply getting the following:

Unable to generate preview
Unable to generate preview.

Without even a clue as to where the issue might be occurring, and as this is a hugely complicated email, this is making debugging almost impossible.

Does anyone know how we can improve the usefulness of the error messaging?

  • Welcome to my nightmare. I've learned to keep as much complex processing out of ExactTarget as possible. AMPscript is a nice tool but it is not a fully functional programming language. There is no error catching or handling. – Jon Sakas Nov 20 '15 at 5:32
2

I'd suggest using Validate in the toolbar. It'll show you more details about any scripting exceptions.

If that doesn't give any indication, comment out your code and add lines back in one at a time until you find the offending piece.

Of course, posting your code would get you the quickest answer, especially around here.

  • Thanks Adam, will take a look at that. Given the complexity of the code in this email I don't think anyone would appreciate me posting the code :) – Paul Moody Nov 17 '15 at 13:10
  • Okay... that didn't prove particularly helpful. "No problems found." – Paul Moody Nov 17 '15 at 13:12
  • 1
    I would check the data inside the fields then. The only two reasons I get this error are if there is an issue with validation (code error or field mismatch) or if the data in the preview is not correctly formatted to be used as the code dictates. – Gortonington Nov 17 '15 at 15:08
  • Everyone that's found a solution or new way to accomplish a SFMC task would appreciate seeing your code. I agree with @Gortonington. It's usually a data/datatype/null/substring problem if the validate comes back clean. – Adam Spriggs Nov 17 '15 at 15:12
1

This is an old question, but I ran into the same issue and found a possible answer... at least what was causing the issue for me. The text version of the email wasn't updating so had some old AMPScript in it that didn't work with the Data Extension I was testing it on. Once I cleared out the old text by hitting 'restore' that solved the problem.

0

I recently encountered same issue + problem with RaiseError() AMPScript function not displaying error messages passed to S1 argument. ET Support needed a month to figure out what's wrong. According to them it's a platform bug. They are fixing it now on our account and will send full bug description when they're done. I'll pass it along when I get any info, that way you can contact ET and request same fix for yours.

  • A bug description from SFMC Support? That'll be the day. – Adam Spriggs Nov 23 '15 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.