4

Hey everyone I've been seeing this a lot lately and am trying to figure out why this error is thrown when querying the SOAP API directly. I've tried several very basic SOQL queries such as

SELECT Body FROM AssetFeed

Only to be met with the sObject type 'AssetFeed' is not supported. error.

The account that I'm currently querying is just a standard user who accepted permission from an app that was created by a Developer Account, so I'm wondering if it might be permissions from the user or permission from the app itself? Possibly because Developer accounts cannot use 95% of whats offered?

The WSDL used is a v27.0 generated Partner WSDL if that helps narrow it down.

I've noticed this in multiple standard objects, so I'm wondering what the trend really is? Seems like a good informational question for future googling of others?

Running describeGlobal()

Array
(
    [0] => AggregateResult
    [1] => Attachment
    [2] => ChatterActivity
    [3] => CollaborationGroup
    [4] => CollaborationGroupFeed
    [5] => CollaborationGroupMember
    [6] => CollaborationGroupMemberRequest
    [7] => CollaborationInvitation
    [8] => ContentDocument
    [9] => ContentDocumentFeed
    [10] => ContentDocumentHistory
    [11] => ContentDocumentLink
    [12] => ContentVersion
    [13] => ContentVersionHistory
    [14] => EntitySubscription
    [15] => FeedComment
    [16] => FeedItem
    [17] => FeedLike
    [18] => FeedTrackedChange
    [19] => Group
    [20] => GroupMember
    [21] => HashtagDefinition
    [22] => Name
    [23] => TaskPriority
    [24] => TaskStatus
    [25] => User
    [26] => UserFeed
    [27] => UserPreference
    [28] => UserRecordAccess
    [29] => UserRole
)

Where would all the rest of my SOAP SObjects be? This seems like a very thin list compared to the 295 SObjects advertised in the documentation

  • 2
    That list is really only the basic system objects. You're missing all sorts of things like Accounts and Contacts. Check your profile and user license - sounds like you might have a chatter only license. – ca_peterson Mar 21 '13 at 5:14
5

Check that the Profile of the User you are using has at least Read Acess to the sObjects you are missing. Also I believe Assets need to be enabled by enabling Products, so worth checking that Products are enabled.

Also you are missing all the standard CRM objects like Account and Contact so worth checking what type of license is assigned to your user, you would need a Salesforce (CRM) license to be able to access the CRM objects.

Additionally, similar to Assets, certain objects become available only when the associated features are enabled eg Product Schedules

2

For custom objects, it is also worth verifying that their Deployment Status is set to "Deployed" rather than "In Development"

1

enter image description here

This may be a solution to this problem

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.