4

I've noticed that Lightning Experience (LE) uses the exact same URL as the S1 Mobile App: /one/one.app

  • Does it mean it is defacto the same app?
  • How can I view the S1 mobile app in my browser as I've done in Summer'15?

I tried to turn off LE again, but navigating then to /one/one.app only brings me:

You can't access Lightning Experience

The page you're trying to access is available from the Salesforce1 mobile app only. Please try again from a supported mobile device. Need help? Ask your Salesforce admin.

enter image description here

For development, support and usability I really don't want to use a mobile device, but I need to be able to access the app. Also I don't want to use an emulator.

4

The only way that Salesforce can tell whether you're accessing the page through a desktop or mobile browser is via the user-agent header. All you need to do is to change that header to identify yourself as a mobile browser.

There are plenty of tools that will help you with this. I use a plugin for Firefox called User Agent Overrider, but I'm sure there are many others.

In IE developer tools you can emulate a Windows Phone, which also allows you to see the SF1 web app.

If you connect programmatically, all you need to do is to add a mobile browser user-agent to your HTTP headers. Enjoy!

1
  • 1
    This autmatism using user-agent is sadly inconvenient and I would have preferd to have a desktop app separated from the mobile app, so that I can run and debug the mobile version on desktop or run the desktop app on mobile for it's extended features. But hacking the user-agent works at least for the debugging use case. – Uwe Heim Dec 18 '16 at 6:52
3

This seems to work (Edit 3 below)

You can make that happen in Chrome Developer Tools (F12) and turn on the device toolbar to pick your device, then use one/one.app and that should be what I think you want...


Original Answer

I used to be able to simply add "/one/one.app" off the back of my URL to test in lightning too.

Now it seems you have to go to Setup | Lightning Experience | Preview Your Org in Lightning Experience to get into lightning (temporarily), then go find the page that you want to see..

Same results, few more clicks, pain, whatev.. Otherwise you get the error you denote, OP.

EDIT: I tried in a different org (on cs17) and it works, and then I thought it might be because I have myDomain configured on the instance where it doesn't work, so I tried another instance with myDomain and URL/one/one.app DOES work.. I'll try to deduce what the settings are..

EDIT2: Looks like you need to enable Lightning Experience to do the URL thing. I prefer Classic to work but sometimes want to look at Lightning so that does work..

EDIT3: I don't have 50 rep to comment on the response below about it looking like a phone but you can make that happen in Chrome Developer Tools (F12) and turn on the device toolbar to pick your device, then use one/one.app and that should be what I think you want...

4
  • This does not answer the question. The way you describe shows only LEX for desktop and not S1 Mobile App for phones inside a desktop browser as requested. – Uwe Heim Mar 7 '17 at 23:10
  • I thought Edit3 answered it (a few hours before your comment?) If so, I'm not appreciative of the -1 haha :-P – CRT Mar 17 '17 at 16:10
  • you are right: this seems to work! Still testing, but so far this provides the best answer to the question. – Uwe Heim Mar 20 '17 at 17:32
  • it is not working anymore. Only Aloha appears on Winter'21. In earlier releases, it did not work very well, too - but it worked partially. Now it does no longer work at all. – Uwe Heim Oct 19 '20 at 13:14
1

I use the plugin below from Josh Birk and works flawless .The only limitation is you have to be on chrome browser

https://chrome.google.com/webstore/detail/s1-demo/kalbgfbifcaigjnkgagbeimcflnaijmc

2
  • Sadly, I'm not happy with Chrome and looking for a solution for Firefox and other Browsers, too... this worked so well and easy. Now it's broken :-( – Uwe Heim Nov 1 '15 at 21:14
  • You may want to tweet @josh or other salesforce evangelist to see if this is feasible at this point .Since the URL will be reserved for lightning i doubt thats even feasible now without some hackery. – Mohith Shrivastava Nov 1 '15 at 21:16
0

You can use the steps defined below:

https://trailhead.salesforce.com/en/content/learn/projects/quickstart-app-builder/quickstart-app-builder4

Or

Download the Chrome extension:

Non- Sandbox: https://chrome.google.com/webstore/detail/salesforce1-simulator/cknbjckicenodbiaejbmkjhldffonggp?hl=en-US

Sandbox: https://chrome.google.com/webstore/detail/salesforce1-sandbox-simul/mgknkgnenlhghpfpdcohmgiejlcaapih?hl=en

Thanks

4
-1

Maybe your lightning experience hasn't been activated.

Go to setup > and in the left gray bar (under the searchbox) should be an option that says "Lightning Experience", go there (read all the things you need) and in the bottom part there is a switch button that says

Lightning Experience You didn't skip to the end, right? Great! You’re ready to flip the switch on a powerful and intuitive user experience.

move the button to the right if it is disabled.

refresh your home and it should add automatically the '/one/one.app' to your url.

Hope that helps.

3
  • 1
    no, this does not help. I want to see S1 in desktop browser, not LEX. – Uwe Heim Dec 18 '16 at 6:46
  • since the release of lighting experience, Salesforce1 IS lightning experience. That's why when you put "/one/one.app" it redirects you to lightning experience. – Dixit Dec 19 '16 at 17:47
  • @UweHeim Before lightning experience our browser changed and looked like a phone, but that's no longer available, it just redirects you to LEX. – Dixit Dec 19 '16 at 17:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.